lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 8 Dec 2020 20:01:59 +0200
From:   Shay Agroskin <shayagr@...zon.com>
To:     Jakub Kicinski <kuba@...nel.org>, <netdev@...r.kernel.org>
CC:     Shay Agroskin <shayagr@...zon.com>,
        David Woodhouse <dwmw@...zon.com>,
        Zorik Machulsky <zorik@...zon.com>,
        Alexander Matushevsky <matua@...zon.com>,
        Bshara Saeed <saeedb@...zon.com>, Matt Wilson <msw@...zon.com>,
        Anthony Liguori <aliguori@...zon.com>,
        Nafea Bshara <nafea@...zon.com>,
        Guy Tzalik <gtzalik@...zon.com>,
        Netanel Belgazal <netanel@...zon.com>,
        Ali Saidi <alisaidi@...zon.com>,
        Benjamin Herrenschmidt <benh@...zon.com>,
        Arthur Kiyanovski <akiyano@...zon.com>,
        Samih Jubran <sameehj@...zon.com>,
        Noam Dagan <ndagan@...zon.com>
Subject: [PATCH net-next v5 0/9] XDP Redirect implementation for ENA driver

Hi all,
ENA is adding XDP Redirect support for its driver and some other
small tweaks.

This series adds the following:

- Make log messages in the driver have a uniform format using
  netdev_* function
- Improve code readability
- Add support for XDP Redirect

v1->v2: Removed the word "atomic" from the name of
	ena_increase_stat_atomic() as it is misleading.

v2->v3: Fixed checkpatch errors

v3->v4: Added an explanation to the decision of using netdev_* prints in
	functions that are also called before netdev is registered.

v4->v5: Added return value check for xdp_do_redirect() and
	xdp_convert_buff_to_frame(). Also replace the variable casting
	in patch 3 with something more readable.

Shay Agroskin (9):
  net: ena: use constant value for net_device allocation
  net: ena: add device distinct log prefix to files
  net: ena: store values in their appropriate variables types
  net: ena: fix coding style nits
  net: ena: aggregate stats increase into a function
  net: ena: use xdp_frame in XDP TX flow
  net: ena: introduce XDP redirect implementation
  net: ena: use xdp_return_frame() to free xdp frames
  net: ena: introduce ndo_xdp_xmit() function for XDP_REDIRECT

 drivers/net/ethernet/amazon/ena/ena_com.c     | 391 ++++++++++-------
 drivers/net/ethernet/amazon/ena/ena_com.h     |  23 +-
 drivers/net/ethernet/amazon/ena/ena_eth_com.c |  71 +--
 drivers/net/ethernet/amazon/ena/ena_eth_com.h |  23 +-
 drivers/net/ethernet/amazon/ena/ena_ethtool.c |   3 +-
 drivers/net/ethernet/amazon/ena/ena_netdev.c  | 403 ++++++++++--------
 drivers/net/ethernet/amazon/ena/ena_netdev.h  |  12 +-
 7 files changed, 551 insertions(+), 375 deletions(-)

-- 
2.17.1

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ