lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 16 Dec 2020 09:15:06 -0700
From:   David Ahern <dsahern@...il.com>
To:     Parav Pandit <parav@...dia.com>, Jakub Kicinski <kuba@...nel.org>,
        Saeed Mahameed <saeed@...nel.org>
Cc:     "David S. Miller" <davem@...emloft.net>,
        Jason Gunthorpe <jgg@...dia.com>,
        Leon Romanovsky <leonro@...dia.com>,
        "netdev@...r.kernel.org" <netdev@...r.kernel.org>,
        "linux-rdma@...r.kernel.org" <linux-rdma@...r.kernel.org>,
        David Ahern <dsahern@...nel.org>,
        Jacob Keller <jacob.e.keller@...el.com>,
        Sridhar Samudrala <sridhar.samudrala@...el.com>,
        "david.m.ertman@...el.com" <david.m.ertman@...el.com>,
        "dan.j.williams@...el.com" <dan.j.williams@...el.com>,
        "kiran.patil@...el.com" <kiran.patil@...el.com>,
        "gregkh@...uxfoundation.org" <gregkh@...uxfoundation.org>,
        Jiri Pirko <jiri@...dia.com>, Vu Pham <vuhuong@...dia.com>,
        Saeed Mahameed <saeedm@...dia.com>
Subject: Re: [net-next v5 05/15] devlink: Support get and set state of port
 function

On 12/15/20 10:15 PM, Parav Pandit wrote:
>>> + * enum devlink_port_function_opstate - indicates operational state
>>> + of port function
>>> + * @DEVLINK_PORT_FUNCTION_OPSTATE_ATTACHED: Driver is attached
>> to the
>>> + function of port,
>> This name definitely needs to be shortened.
>>
> DEVLINK_PORT_FUNCTION_OPS_ATTACHED
> Or
> DEVLINK_PF_OPS_ATTACHED 
> 
> PF - port function
>  

The devlink attribute names need to start using established short names
to find that balance between readability and ridiculously long names.

In this case PF for networking has an established link to SRIOV
'physical function'.

FUNCTION can be written as FCN.
ATTACHED can be shortened to ATTCH.

So in this case DEVLINK_PORT_FUNCTION_OPSTATE_ATTACHED (38 chars) drops
to DEVLINK_PORT_FCN_OPSTATE_ATTCH (30 chars). That is a step in the
right direction.



Powered by blists - more mailing lists