[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20201218201633.2735367-1-jonathan.lemon@gmail.com>
Date: Fri, 18 Dec 2020 12:16:24 -0800
From: Jonathan Lemon <jonathan.lemon@...il.com>
To: <netdev@...r.kernel.org>, <edumazet@...gle.com>,
<willemdebruijn.kernel@...il.com>
CC: <kernel-team@...com>
Subject: [PATCH 0/9 v1 RFC] Generic zcopy_* functions
From: Jonathan Lemon <bsd@...com>
This is set of cleanup patches for zerocopy which are intended
to allow a introduction of a different zerocopy implementation.
The top level api will use the skb_zcopy_*() functions, while
the current TCP specific zerocopy would use the sock_zerocopy_*()
calls.
There should be no functional changes from these patches.
Patch 1:
Move zerocopy bits from tx_flags into zc_flags for clarity.
These bits will be used in the RX path in the future.
Patch 2: remove dead function
Patch 3:
Replace sock_zerocopy_put() with skb_zcopy_put(), moving
the zerocopy logic into sock_zerocopy_callback(). Push the
refcounting into the callback, since not all implemenetations
will have a refcount.
Patch 4: rename sock_zerocopy_get for consistency.
Patch 5:
Add an optional skb parameter to callback, allowing access to
the attached skb from the callback.
Patch 6:
Add skb_zcopy_put_abort, and move zerocopy logic into the
callback function. There unfortunately is still a check
against the callback type here.
Patch 7:
Set the skb zc_flags from the ubuf being attached, instead
of a fixed value, allowing different initialization types.
Patch 8: Replace open-coded assignments
Patch 9: Relocate skb_zcopy_clear() in skb_release_data()
Jonathan Lemon (9):
net: group skb_shinfo zerocopy related bits together.
skbuff: remove unused skb_zcopy_abort function
skbuff: replace sock_zerocopy_put() with skb_zcopy_put()
skbuff: replace sock_zerocopy_get with skb_zcopy_get
skbuff: Add skb parameter to the ubuf zerocopy callback
skbuff: Call sock_zerocopy_put_abort from skb_zcopy_put_abort
skbuff: add zc_flags to ubuf_info for ubuf setup
tap/tun: use skb_zcopy_set() instead of open coded assignment
skbuff: Call skb_zcopy_clear() before unref'ing fragments
drivers/net/tap.c | 6 +--
drivers/net/tun.c | 6 +--
drivers/net/xen-netback/common.h | 3 +-
drivers/net/xen-netback/interface.c | 4 +-
drivers/net/xen-netback/netback.c | 7 +--
drivers/vhost/net.c | 4 +-
include/linux/skbuff.h | 77 +++++++++++++++--------------
net/core/skbuff.c | 48 +++++++++---------
net/ipv4/ip_output.c | 3 +-
net/ipv4/tcp.c | 6 +--
net/ipv6/ip6_output.c | 3 +-
net/kcm/kcmsock.c | 4 +-
12 files changed, 85 insertions(+), 86 deletions(-)
--
2.24.1
Powered by blists - more mailing lists