lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 21 Dec 2020 16:09:14 -0800
From:   Jonathan Lemon <jonathan.lemon@...il.com>
To:     <netdev@...r.kernel.org>, <edumazet@...gle.com>,
        <willemdebruijn.kernel@...il.com>
CC:     <kernel-team@...com>
Subject: [PATCH 00/12 v2 RFC]  Generic zcopy_* functions

From: Jonathan Lemon <bsd@...com>

This is set of cleanup patches for zerocopy which are intended
to allow a introduction of a different zerocopy implementation.

The top level API will use the skb_zcopy_*() functions, while
the current TCP specific zerocopy ends up using msg_zerocopy_*()
calls.

There should be no functional changes from these patches.

v1->v2:
 Break changes to skb_zcopy_put into 3 patches, in order to
 make it easier to follow the changes.  Add Willem's suggestion
 about renaming sock_zerocopy_

Patch 1:
  Move zerocopy bits from tx_flags into zc_flags for clarity.
  These bits will be used in the RX path in the future.
Patch 2: remove dead function
Patch 3: simplify sock_zerocopy_put
Patch 4: push status/refcounts into sock_zerocopy_callback
Patch 5: replace sock_zerocopy_put with skb_zcopy_put
Patch 6: rename sock_zerocopy_get
Patch 7:
  Add an optional skb parameter to callback, allowing access to
  the attached skb from the callback.
Patch 8:
  Add skb_zcopy_put_abort, and move zerocopy logic into the
  callback function.  There unfortunately is still a check
  against the callback type here.
Patch 9:
  Set the skb zc_flags from the ubuf being attached, instead
  of a fixed value, allowing different initialization types.
Patch 10: Replace open-coded assignments
Patch 11: Relocate skb_zcopy_clear() in skb_release_data()
Patch 12: rename sock_zerocopy_ to msg_zerocpy_

Jonathan Lemon (12):
  net: group skb_shinfo zerocopy related bits together.
  skbuff: remove unused skb_zcopy_abort function
  skbuff: simplify sock_zerocopy_put
  skbuff: Push status and refcounts into sock_zerocopy_callback
  skbuff: replace sock_zerocopy_put() with skb_zcopy_put()
  skbuff: replace sock_zerocopy_get with skb_zcopy_get
  skbuff: Add skb parameter to the ubuf zerocopy callback
  skbuff: Call sock_zerocopy_put_abort from skb_zcopy_put_abort
  skbuff: add zc_flags to ubuf_info for ubuf setup
  tap/tun: use skb_zcopy_set() instead of open coded assignment
  skbuff: Call skb_zcopy_clear() before unref'ing fragments
  skbuff: rename sock_zerocopy_* to msg_zerocopy_*

 drivers/net/tap.c                   |  6 +-
 drivers/net/tun.c                   |  6 +-
 drivers/net/xen-netback/common.h    |  3 +-
 drivers/net/xen-netback/interface.c |  4 +-
 drivers/net/xen-netback/netback.c   |  7 ++-
 drivers/vhost/net.c                 |  4 +-
 include/linux/skbuff.h              | 95 +++++++++++++++--------------
 net/core/skbuff.c                   | 66 ++++++++++----------
 net/ipv4/ip_output.c                |  5 +-
 net/ipv4/tcp.c                      |  8 +--
 net/ipv6/ip6_output.c               |  5 +-
 net/kcm/kcmsock.c                   |  4 +-
 12 files changed, 106 insertions(+), 107 deletions(-)

-- 
2.24.1

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ