[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20210105220706.998374-1-jonathan.lemon@gmail.com>
Date: Tue, 5 Jan 2021 14:06:53 -0800
From: Jonathan Lemon <jonathan.lemon@...il.com>
To: <netdev@...r.kernel.org>, <davem@...emloft.net>, <kuba@...nel.org>,
<willemdebruijn.kernel@...il.com>, <edumazet@...gle.com>,
<dsahern@...il.com>
CC: <kernel-team@...com>
Subject: [PATCH net-next v1 00/13] Generic zcopy_* functions
From: Jonathan Lemon <bsd@...com>
This is set of cleanup patches for zerocopy which are intended
to allow a introduction of a different zerocopy implementation.
The top level API will use the skb_zcopy_*() functions, while
the current TCP specific zerocopy ends up using msg_zerocopy_*()
calls.
There should be no functional changes from these patches.
Patch 1: remove dead function
Patch 2: simplify sock_zerocopy_put
Patch 3: push status/refcounts into sock_zerocopy_callback
Patch 4: replace sock_zerocopy_put with skb_zcopy_put
Patch 5: rename sock_zerocopy_get
Patch 6:
Add an optional skb parameter to callback, allowing access to
the attached skb from the callback.
Patch 7:
Add skb_zcopy_put_abort, and move zerocopy logic into the
callback function. There unfortunately is still a check
against the callback type here.
Patch 8: Relocate skb_zcopy_clear() in skb_release_data()
Patch 9: rename sock_zerocopy_ to msg_zerocopy_
Patch 10:
Move zerocopy bits from tx_flags into flags for clarity.
These bits will be used in the RX path in the future.
Patch 11:
Set the skb flags from the ubuf being attached, instead
of a fixed value, allowing different initialization types.
Patch 12: Replace open-coded assignments with skb_zcopy_init()
Patch 13: Rename skb_zcopy_{get|put} to net_zcopy_{get|put}
Jonathan Lemon (13):
skbuff: remove unused skb_zcopy_abort function
skbuff: simplify sock_zerocopy_put
skbuff: Push status and refcounts into sock_zerocopy_callback
skbuff: replace sock_zerocopy_put() with skb_zcopy_put()
skbuff: replace sock_zerocopy_get with skb_zcopy_get
skbuff: Add skb parameter to the ubuf zerocopy callback
skbuff: Call sock_zerocopy_put_abort from skb_zcopy_put_abort
skbuff: Call skb_zcopy_clear() before unref'ing fragments
skbuff: rename sock_zerocopy_* to msg_zerocopy_*
net: group skb_shinfo zerocopy related bits together.
skbuff: add flags to ubuf_info for ubuf setup
tap/tun: add skb_zcopy_init() helper for initialization.
skbuff: Rename skb_zcopy_{get|put} to net_zcopy_{get|put}
drivers/net/tap.c | 6 +-
drivers/net/tun.c | 6 +-
drivers/net/xen-netback/common.h | 3 +-
drivers/net/xen-netback/interface.c | 4 +-
drivers/net/xen-netback/netback.c | 5 +-
drivers/vhost/net.c | 4 +-
include/linux/skbuff.h | 106 +++++++++++++++-------------
net/core/skbuff.c | 65 ++++++++---------
net/ipv4/ip_output.c | 5 +-
net/ipv4/tcp.c | 8 +--
net/ipv6/ip6_output.c | 5 +-
net/kcm/kcmsock.c | 4 +-
12 files changed, 113 insertions(+), 108 deletions(-)
--
2.24.1
Powered by blists - more mailing lists