lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 26 Apr 2021 20:54:34 -0700
From:   Stephen Hemminger <stephen@...workplumber.org>
To:     Andreas Roeseler <andreas.a.roeseler@...il.com>
Cc:     netdev@...r.kernel.org, davem@...emloft.net,
        yoshfuji@...ux-ipv6.org, dsahern@...nel.org, kuba@...nel.org
Subject: Re: [PATCH net-next] icmp: standardize naming of RFC 8335 PROBE
 constants

On Mon, 26 Apr 2021 22:40:02 -0500
Andreas Roeseler <andreas.a.roeseler@...il.com> wrote:

> The current definitions of constants for PROBE are inconsistent, with
> some beginning with ICMP and others with simply EXT. This patch
> attempts to standardize the naming conventions of the constants for
> PROBE, and update the relevant definitions in net/ipv4/icmp.c.
> 
> Similarly, the definitions for the code field (previously
> ICMP_EXT_MAL_QUERY, etc) use the same prefixes as the type field. This
> patch adds _CODE_ to the prefix to clarify the distinction of these
> constants.
> 
> Signed-off-by: Andreas Roeseler <andreas.a.roeseler@...il.com>
> ---
>  include/uapi/linux/icmp.h | 28 ++++++++++++++--------------
>  net/ipv4/icmp.c           | 16 ++++++++--------
>  2 files changed, 22 insertions(+), 22 deletions(-)
> 
> diff --git a/include/uapi/linux/icmp.h b/include/uapi/linux/icmp.h
> index 222325d1d80e..c1da8244c5e1 100644
> --- a/include/uapi/linux/icmp.h
> +++ b/include/uapi/linux/icmp.h
> @@ -70,22 +70,22 @@
>  #define ICMP_EXC_FRAGTIME	1	/* Fragment Reass time exceeded	*/
>  
>  /* Codes for EXT_ECHO (PROBE) */
> -#define ICMP_EXT_ECHO		42
> -#define ICMP_EXT_ECHOREPLY	43
> -#define ICMP_EXT_MAL_QUERY	1	/* Malformed Query */
> -#define ICMP_EXT_NO_IF		2	/* No such Interface */
> -#define ICMP_EXT_NO_TABLE_ENT	3	/* No such Table Entry */
> -#define ICMP_EXT_MULT_IFS	4	/* Multiple Interfaces Satisfy Query */
> +#define ICMP_EXT_ECHO			42
> +#define ICMP_EXT_ECHOREPLY		43
> +#define ICMP_EXT_CODE_MAL_QUERY		1	/* Malformed Query */
> +#define ICMP_EXT_CODE_NO_IF		2	/* No such Interface */
> +#define ICMP_EXT_CODE_NO_TABLE_ENT	3	/* No such Table Entry */
> +#define ICMP_EXT_CODE_MULT_IFS		4	/* Multiple Interfaces Satisfy Query */
>  
>  /* Constants for EXT_ECHO (PROBE) */
> -#define EXT_ECHOREPLY_ACTIVE	(1 << 2)/* active bit in reply message */
> -#define EXT_ECHOREPLY_IPV4	(1 << 1)/* ipv4 bit in reply message */
> -#define EXT_ECHOREPLY_IPV6	1	/* ipv6 bit in reply message */
> -#define EXT_ECHO_CTYPE_NAME	1
> -#define EXT_ECHO_CTYPE_INDEX	2
> -#define EXT_ECHO_CTYPE_ADDR	3
> -#define ICMP_AFI_IP		1	/* Address Family Identifier for ipv4 */
> -#define ICMP_AFI_IP6		2	/* Address Family Identifier for ipv6 */
> +#define ICMP_EXT_ECHOREPLY_ACTIVE	(1 << 2)/* active bit in reply message */
> +#define ICMP_EXT_ECHOREPLY_IPV4		(1 << 1)/* ipv4 bit in reply message */
> +#define ICMP_EXT_ECHOREPLY_IPV6		1	/* ipv6 bit in reply message */
> +#define ICMP_EXT_ECHO_CTYPE_NAME	1
> +#define ICMP_EXT_ECHO_CTYPE_INDEX	2
> +#define ICMP_EXT_ECHO_CTYPE_ADDR	3
> +#define ICMP_AFI_IP			1	/* Address Family Identifier for ipv4 */
> +#define ICMP_AFI_IP6			2	/* Address Family Identifier for ipv6 */

You can't just remove the old constants. They have to stay there.
The #defines are part of the Linux API by now.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ