lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 8 Jun 2021 19:01:08 +0300
From:   Shay Agroskin <shayagr@...zon.com>
To:     David Miller <davem@...emloft.net>,
        Jakub Kicinski <kuba@...nel.org>, <netdev@...r.kernel.org>
CC:     Shay Agroskin <shayagr@...zon.com>,
        "Woodhouse, David" <dwmw@...zon.com>,
        "Machulsky, Zorik" <zorik@...zon.com>,
        "Matushevsky, Alexander" <matua@...zon.com>,
        Saeed Bshara <saeedb@...zon.com>,
        "Wilson, Matt" <msw@...zon.com>,
        "Liguori, Anthony" <aliguori@...zon.com>,
        "Bshara, Nafea" <nafea@...zon.com>,
        "Belgazal, Netanel" <netanel@...zon.com>,
        "Saidi, Ali" <alisaidi@...zon.com>,
        "Herrenschmidt, Benjamin" <benh@...zon.com>,
        "Kiyanovski, Arthur" <akiyano@...zon.com>,
        "Dagan, Noam" <ndagan@...zon.com>
Subject: [Patch v1 net-next 00/10] Use build_skb and reorganize some code in ENA

Hi all,
this patchset introduces several changes:

- Use build_skb() on RX side.
  This allows to ensure that the headers are in the linear part

- Batch some code into functions and remove some of the code to make it more
  readable and less error prone

- Fix RST format and outdated description in ENA documentation

- Improve cache alignment in the code

Please review

Shay Agroskin (10):
  net: ena: optimize data access in fast-path code
  net: ena: Remove unused code
  net: ena: Improve error logging in driver
  net: ena: use build_skb() in RX path
  net: ena: add jiffies of last napi call to stats
  net: ena: Remove module param and change message severity
  net: ena: fix RST format in ENA documentation file
  net: ena: aggregate doorbell common operations into a function
  net: ena: Use dev_alloc() in RX buffer allocation
  net: ena: re-organize code to improve readability

 .../device_drivers/ethernet/amazon/ena.rst    | 164 +++++++------
 .../net/ethernet/amazon/ena/ena_admin_defs.h  |   2 -
 drivers/net/ethernet/amazon/ena/ena_com.c     |   3 +-
 drivers/net/ethernet/amazon/ena/ena_eth_com.c |  30 ++-
 drivers/net/ethernet/amazon/ena/ena_ethtool.c |  18 +-
 drivers/net/ethernet/amazon/ena/ena_netdev.c  | 216 ++++++++++--------
 drivers/net/ethernet/amazon/ena/ena_netdev.h  |  23 +-
 7 files changed, 249 insertions(+), 207 deletions(-)

-- 
2.25.1

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ