[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <41183a98-bdb9-4ad6-7eab-5a7292a6df84@rasmusvillemoes.dk>
Date: Wed, 28 Jul 2021 12:54:18 +0200
From: Rasmus Villemoes <linux@...musvillemoes.dk>
To: Kees Cook <keescook@...omium.org>, linux-hardening@...r.kernel.org
Cc: Keith Packard <keithpac@...zon.com>,
"Gustavo A. R. Silva" <gustavoars@...nel.org>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Andrew Morton <akpm@...ux-foundation.org>,
linux-kernel@...r.kernel.org, linux-wireless@...r.kernel.org,
netdev@...r.kernel.org, dri-devel@...ts.freedesktop.org,
linux-staging@...ts.linux.dev, linux-block@...r.kernel.org,
linux-kbuild@...r.kernel.org, clang-built-linux@...glegroups.com
Subject: Re: [PATCH 04/64] stddef: Introduce struct_group() helper macro
On 27/07/2021 22.57, Kees Cook wrote:
> In order to have a regular programmatic way to describe a struct
> region that can be used for references and sizing, can be examined for
> bounds checking, avoids forcing the use of intermediate identifiers,
> and avoids polluting the global namespace, introduce the struct_group()
> macro. This macro wraps the member declarations to create an anonymous
> union of an anonymous struct (no intermediate name) and a named struct
> (for references and sizing):
>
> struct foo {
> int one;
> struct_group(thing,
> int two,
> int three,
> );
> int four;
> };
That example won't compile, the commas after two and three should be
semicolons.
And your implementation relies on MEMBERS not containing any comma
tokens, but as
int a, b, c, d;
is a valid way to declare multiple members, consider making MEMBERS
variadic
#define struct_group(NAME, MEMBERS...)
to have it slurp up every subsequent argument and make that work.
>
> Co-developed-by: Keith Packard <keithpac@...zon.com>
> Signed-off-by: Keith Packard <keithpac@...zon.com>
> Signed-off-by: Kees Cook <keescook@...omium.org>
> ---
> include/linux/stddef.h | 34 ++++++++++++++++++++++++++++++++++
Bikeshedding a bit, but do we need to add 34 lines that need to be
preprocessed to virtually each and every translation unit [as opposed to
adding a struct_group.h header]? Oh well, you need it for struct
skbuff.h, so it would be pulled in by a lot regardless :(
Rasmus
Powered by blists - more mailing lists