[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <OS0PR01MB5922BC0F748E4FDC4FA904EB86F09@OS0PR01MB5922.jpnprd01.prod.outlook.com>
Date: Tue, 3 Aug 2021 07:13:26 +0000
From: Biju Das <biju.das.jz@...renesas.com>
To: Sergei Shtylyov <sergei.shtylyov@...il.com>,
"David S. Miller" <davem@...emloft.net>,
Jakub Kicinski <kuba@...nel.org>
CC: Geert Uytterhoeven <geert+renesas@...der.be>,
Sergey Shtylyov <s.shtylyov@...russia.ru>,
Adam Ford <aford173@...il.com>, Andrew Lunn <andrew@...n.ch>,
Yuusuke Ashizuka <ashiduka@...itsu.com>,
Yoshihiro Shimoda <yoshihiro.shimoda.uh@...esas.com>,
"netdev@...r.kernel.org" <netdev@...r.kernel.org>,
"linux-renesas-soc@...r.kernel.org"
<linux-renesas-soc@...r.kernel.org>,
Chris Paterson <Chris.Paterson2@...esas.com>,
Biju Das <biju.das@...renesas.com>,
Prabhakar Mahadev Lad <prabhakar.mahadev-lad.rj@...renesas.com>
Subject: RE: [PATCH net-next v2 2/8] ravb: Add skb_sz to struct ravb_hw_info
Hi Sergei,
Thanks for the feedback.
> Subject: Re: [PATCH net-next v2 2/8] ravb: Add skb_sz to struct
> ravb_hw_info
>
> On 8/2/21 1:26 PM, Biju Das wrote:
>
> > The maximum descriptor size that can be specified on the reception
> > side for R-Car is 2048 bytes, whereas for RZ/G2L it is 8096.
> >
> > Add the skb_size variable to struct ravb_hw_info for allocating
> > different skb buffer sizes for R-Car and RZ/G2L using the
> netdev_alloc_skb function.
> >
> > Signed-off-by: Biju Das <biju.das.jz@...renesas.com>
> > Reviewed-by: Lad Prabhakar <prabhakar.mahadev-lad.rj@...renesas.com>
> > ---
> > v2:
> > * Incorporated Andrew and Sergei's review comments for making it
> smaller patch
> > and provided detailed description.
> > ---
> > drivers/net/ethernet/renesas/ravb.h | 1 +
> > drivers/net/ethernet/renesas/ravb_main.c | 10 ++++++----
> > 2 files changed, 7 insertions(+), 4 deletions(-)
> >
> > diff --git a/drivers/net/ethernet/renesas/ravb.h
> > b/drivers/net/ethernet/renesas/ravb.h
> > index cfb972c05b34..16d1711a0731 100644
> > --- a/drivers/net/ethernet/renesas/ravb.h
> > +++ b/drivers/net/ethernet/renesas/ravb.h
> > @@ -991,6 +991,7 @@ enum ravb_chip_id { struct ravb_hw_info {
> > enum ravb_chip_id chip_id;
> > int num_tx_desc;
> > + size_t skb_sz;
>
> Bad naming -- refers to software ISO hatdware, I suggest max_rx_len or
> s/th of that sort.
From the api description
* netdev_alloc_skb - allocate an skbuff for rx on a specific device
* @length: length to allocate
Since it allocates skbuff, I thought skb_sz (size of skb buffer) is a good name.
Is there any restriction in Linux, not to use skb_sz because of
"software ISO hardware" as you mentioned?
I may have chosen bad name because of this restriction.
Please correct me, if that is the case.
Regards,
Biju
Powered by blists - more mailing lists