[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <3f3fc268-10fc-1917-32c2-dc0e7737dc48@kaspersky.com>
Date: Mon, 23 Aug 2021 21:41:16 +0300
From: Arseny Krasnov <arseny.krasnov@...persky.com>
To: Stefan Hajnoczi <stefanha@...hat.com>,
Stefano Garzarella <sgarzare@...hat.com>,
"Michael S. Tsirkin" <mst@...hat.com>,
Jason Wang <jasowang@...hat.com>,
"David S. Miller" <davem@...emloft.net>,
Jakub Kicinski <kuba@...nel.org>,
Norbert Slusarek <nslusarek@....net>,
Andra Paraschiv <andraprs@...zon.com>,
Colin Ian King <colin.king@...onical.com>
CC: "kvm@...r.kernel.org" <kvm@...r.kernel.org>,
"virtualization@...ts.linux-foundation.org"
<virtualization@...ts.linux-foundation.org>,
"netdev@...r.kernel.org" <netdev@...r.kernel.org>,
"linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>,
"stsp2@...dex.ru" <stsp2@...dex.ru>, <oxffffaa@...il.com>
Subject: Re: [RFC PATCH v3 0/6] virtio/vsock: introduce MSG_EOR flag for
SEQPACKET
Hello, please ping :)
On 16.08.2021 11:50, Arseny Krasnov wrote:
> This patchset implements support of MSG_EOR bit for SEQPACKET
> AF_VSOCK sockets over virtio transport.
> First we need to define 'messages' and 'records' like this:
> Message is result of sending calls: 'write()', 'send()', 'sendmsg()'
> etc. It has fixed maximum length, and it bounds are visible using
> return from receive calls: 'read()', 'recv()', 'recvmsg()' etc.
> Current implementation based on message definition above.
> Record has unlimited length, it consists of multiple message,
> and bounds of record are visible via MSG_EOR flag returned from
> 'recvmsg()' call. Sender passes MSG_EOR to sending system call and
> receiver will see MSG_EOR when corresponding message will be processed.
> Idea of patchset comes from POSIX: it says that SEQPACKET
> supports record boundaries which are visible for receiver using
> MSG_EOR bit. So, it looks like MSG_EOR is enough thing for SEQPACKET
> and we don't need to maintain boundaries of corresponding send -
> receive system calls. But, for 'sendXXX()' and 'recXXX()' POSIX says,
> that all these calls operates with messages, e.g. 'sendXXX()' sends
> message, while 'recXXX()' reads messages and for SEQPACKET, 'recXXX()'
> must read one entire message from socket, dropping all out of size
> bytes. Thus, both message boundaries and MSG_EOR bit must be supported
> to follow POSIX rules.
> To support MSG_EOR new bit was added along with existing
> 'VIRTIO_VSOCK_SEQ_EOR': 'VIRTIO_VSOCK_SEQ_EOM'(end-of-message) - now it
> works in the same way as 'VIRTIO_VSOCK_SEQ_EOR'. But 'VIRTIO_VSOCK_SEQ_EOR'
> is used to mark 'MSG_EOR' bit passed from userspace.
> This patchset includes simple test for MSG_EOR.
>
> Arseny Krasnov(6):
> virtio/vsock: rename 'EOR' to 'EOM' bit.
> virtio/vsock: add 'VIRTIO_VSOCK_SEQ_EOR' bit.
> vhost/vsock: support MSG_EOR bit processing
> virtio/vsock: support MSG_EOR bit processing
> af_vsock: rename variables in receive loop
> vsock_test: update message bounds test for MSG_EOR
>
> drivers/vhost/vsock.c | 22 +++++++++++++---------
> include/uapi/linux/virtio_vsock.h | 3 ++-
> net/vmw_vsock/af_vsock.c | 10 +++++-----
> net/vmw_vsock/virtio_transport_common.c | 23 +++++++++++++++--------
> tools/testing/vsock/vsock_test.c | 8 +++++++-
> 5 files changed, 42 insertions(+), 24 deletions(-)
>
> v2 -> v3:
> - 'virtio/vsock: rename 'EOR' to 'EOM' bit.' - commit message updated.
> - 'VIRTIO_VSOCK_SEQ_EOR' bit add moved to separate patch.
> - 'vhost/vsock: support MSG_EOR bit processing' - commit message
> updated.
> - 'vhost/vsock: support MSG_EOR bit processing' - removed unneeded
> 'le32_to_cpu()', because input argument was already in CPU
> endianness.
>
> v1 -> v2:
> - 'VIRTIO_VSOCK_SEQ_EOR' is renamed to 'VIRTIO_VSOCK_SEQ_EOM', to
> support backward compatibility.
> - use bitmask of flags to restore in vhost.c, instead of separated
> bool variable for each flag.
> - test for EAGAIN removed, as logically it is not part of this
> patchset(will be sent separately).
> - cover letter updated(added part with POSIX description).
>
> Signed-off-by: Arseny Krasnov <arseny.krasnov@...persky.com>
>
Powered by blists - more mailing lists