[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <63592646-7547-1a81-e6c3-5bac413cb94a@omp.ru>
Date: Wed, 6 Oct 2021 22:38:55 +0300
From: Sergey Shtylyov <s.shtylyov@....ru>
To: Biju Das <biju.das.jz@...renesas.com>,
"David S. Miller" <davem@...emloft.net>,
Jakub Kicinski <kuba@...nel.org>
CC: Sergei Shtylyov <sergei.shtylyov@...il.com>,
Geert Uytterhoeven <geert+renesas@...der.be>,
Sergey Shtylyov <s.shtylyov@...russia.ru>,
"Adam Ford" <aford173@...il.com>, Andrew Lunn <andrew@...n.ch>,
Yuusuke Ashizuka <ashiduka@...itsu.com>,
Yoshihiro Shimoda <yoshihiro.shimoda.uh@...esas.com>,
<netdev@...r.kernel.org>, <linux-renesas-soc@...r.kernel.org>,
Chris Paterson <Chris.Paterson2@...esas.com>,
Biju Das <biju.das@...renesas.com>,
"Prabhakar Mahadev Lad" <prabhakar.mahadev-lad.rj@...renesas.com>
Subject: Re: [RFC 07/12] ravb: Fillup ravb_rx_gbeth() stub
On 10/5/21 2:06 PM, Biju Das wrote:
> Fillup ravb_rx_gbeth() function to support RZ/G2L.
>
> This patch also renames ravb_rcar_rx to ravb_rx_rcar to be
> consistent with the naming convention used in sh_eth driver.
>
> Signed-off-by: Biju Das <biju.das.jz@...renesas.com>
> Reviewed-by: Lad Prabhakar <prabhakar.mahadev-lad.rj@...renesas.com>[...]
> diff --git a/drivers/net/ethernet/renesas/ravb_main.c b/drivers/net/ethernet/renesas/ravb_main.c
> index 37164a983156..42573eac82b9 100644
> --- a/drivers/net/ethernet/renesas/ravb_main.c
> +++ b/drivers/net/ethernet/renesas/ravb_main.c
> @@ -720,6 +720,23 @@ static void ravb_get_tx_tstamp(struct net_device *ndev)
> }
> }
>
> +static void ravb_rx_csum_gbeth(struct sk_buff *skb)
> +{
> + u8 *hw_csum;
> +
> + /* The hardware checksum is contained in sizeof(__sum16) (2) bytes
> + * appended to packet data
> + */
> + if (unlikely(skb->len < sizeof(__sum16)))
> + return;
> + hw_csum = skb_tail_pointer(skb) - sizeof(__sum16);
Not 32-bit? The manual says the IP checksum is stored in the first 2 bytes.
> +
> + if (*hw_csum == 0)
You only check the 1st byte, not the full checksum!
> + skb->ip_summed = CHECKSUM_UNNECESSARY;
> + else
> + skb->ip_summed = CHECKSUM_NONE;
So the TCP/UDP/ICMP checksums are not dealt with? Why enable them then?
> +}
> +
> static void ravb_rx_csum(struct sk_buff *skb)
static void ravb_rx_csum_rcar(struct sk_buff *skb)?
[...]
MBR, Sergey
Powered by blists - more mailing lists