[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <7c31964b-8cde-50c5-d686-939b7c5bd7f0@omp.ru>
Date: Wed, 6 Oct 2021 23:32:13 +0300
From: Sergey Shtylyov <s.shtylyov@....ru>
To: Biju Das <biju.das.jz@...renesas.com>,
"David S. Miller" <davem@...emloft.net>,
Jakub Kicinski <kuba@...nel.org>
CC: Sergei Shtylyov <sergei.shtylyov@...il.com>,
Geert Uytterhoeven <geert+renesas@...der.be>,
Sergey Shtylyov <s.shtylyov@...russia.ru>,
"Adam Ford" <aford173@...il.com>, Andrew Lunn <andrew@...n.ch>,
Yuusuke Ashizuka <ashiduka@...itsu.com>,
Yoshihiro Shimoda <yoshihiro.shimoda.uh@...esas.com>,
"netdev@...r.kernel.org" <netdev@...r.kernel.org>,
"linux-renesas-soc@...r.kernel.org"
<linux-renesas-soc@...r.kernel.org>,
Chris Paterson <Chris.Paterson2@...esas.com>,
Biju Das <biju.das@...renesas.com>,
Prabhakar Mahadev Lad <prabhakar.mahadev-lad.rj@...renesas.com>
Subject: Re: [RFC 07/12] ravb: Fillup ravb_rx_gbeth() stub
On 10/6/21 11:22 PM, Biju Das wrote:
[...]
>>> Fillup ravb_rx_gbeth() function to support RZ/G2L.
>>>
>>> This patch also renames ravb_rcar_rx to ravb_rx_rcar to be consistent
>>> with the naming convention used in sh_eth driver.
>>>
>>> Signed-off-by: Biju Das <biju.das.jz@...renesas.com>
>>> Reviewed-by: Lad Prabhakar
>>> <prabhakar.mahadev-lad.rj@...renesas.com>[...]
>>> diff --git a/drivers/net/ethernet/renesas/ravb_main.c
>>> b/drivers/net/ethernet/renesas/ravb_main.c
>>> index 37164a983156..42573eac82b9 100644
>>> --- a/drivers/net/ethernet/renesas/ravb_main.c
>>> +++ b/drivers/net/ethernet/renesas/ravb_main.c
>>> @@ -720,6 +720,23 @@ static void ravb_get_tx_tstamp(struct net_device
>> *ndev)
>>> }
>>> }
>>>
>>> +static void ravb_rx_csum_gbeth(struct sk_buff *skb) {
>>> + u8 *hw_csum;
>>> +
>>> + /* The hardware checksum is contained in sizeof(__sum16) (2) bytes
>>> + * appended to packet data
>>> + */
>>> + if (unlikely(skb->len < sizeof(__sum16)))
>>> + return;
>>> + hw_csum = skb_tail_pointer(skb) - sizeof(__sum16);
>>
>> Not 32-bit? The manual says the IP checksum is stored in the first 2
>> bytes.
>
> It is 16 bit. It is on last 2 bytes.
So you're saying the manual is wrong?
>>
>>> +
>>> + if (*hw_csum == 0)
>>
>> You only check the 1st byte, not the full checksum!
>
> As I said earlier, "0" value on last 16 bit, means no checksum error.
How's that? 'hw_csum' is declaread as 'u8 *'!
>>> + skb->ip_summed = CHECKSUM_UNNECESSARY;
>>> + else
>>> + skb->ip_summed = CHECKSUM_NONE;
>>
>> So the TCP/UDP/ICMP checksums are not dealt with? Why enable them then?
>
> If last 2bytes is zero, means there is no checksum error w.r.to TCP/UDP/ICMP checksums.
Why checksum them independently then?
> RZ/G2L checksum part is different from R-Car Gen3. There is no TOE block at all for R-Car Gen3.
>
> Regards,
> Biju
[...]
MBR, Sergey
Powered by blists - more mailing lists