[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20211008215946.3961353-1-swboyd@chromium.org>
Date: Fri, 8 Oct 2021 14:59:45 -0700
From: Stephen Boyd <swboyd@...omium.org>
To: "David S . Miller" <davem@...emloft.net>,
Jakub Kicinski <kuba@...nel.org>
Cc: linux-kernel@...r.kernel.org, netdev@...r.kernel.org,
Jiang Wang <jiang.wang@...edance.com>,
Andrii Nakryiko <andrii@...nel.org>,
Cong Wang <cong.wang@...edance.com>,
Jakub Sitnicki <jakub@...udflare.com>,
John Fastabend <john.fastabend@...il.com>,
Dmitry Osipenko <digetx@...il.com>
Subject: [PATCH] af_unix: Rename UNIX-DGRAM to UNIX to maintain backwards compatability
Then name of this protocol changed in commit 94531cfcbe79 ("af_unix: Add
unix_stream_proto for sockmap") because that commit added stream support
to the af_unix protocol. Renaming the existing protocol makes a ChromeOS
protocol test[1] fail now that the name has changed in
/proc/net/protocols from "UNIX" to "UNIX-DGRAM".
Let's put the name back to how it was while keeping the stream protocol
as "UNIX-STREAM" so that the procfs interface doesn't change. This fixes
the test and maintains backwards compatibility in proc.
Cc: Jiang Wang <jiang.wang@...edance.com>
Cc: Andrii Nakryiko <andrii@...nel.org>
Cc: Cong Wang <cong.wang@...edance.com>
Cc: Jakub Sitnicki <jakub@...udflare.com>
Cc: John Fastabend <john.fastabend@...il.com>
Cc: Dmitry Osipenko <digetx@...il.com>
Link: https://source.chromium.org/chromiumos/chromiumos/codesearch/+/main:src/platform/tast-tests/src/chromiumos/tast/local/bundles/cros/network/supported_protocols.go;l=50;drc=e8b1c3f94cb40a054f4aa1ef1aff61e75dc38f18 [1]
Fixes: 94531cfcbe79 ("af_unix: Add unix_stream_proto for sockmap")
Signed-off-by: Stephen Boyd <swboyd@...omium.org>
---
net/unix/af_unix.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/net/unix/af_unix.c b/net/unix/af_unix.c
index efac5989edb5..26f92325d94b 100644
--- a/net/unix/af_unix.c
+++ b/net/unix/af_unix.c
@@ -828,7 +828,7 @@ static void unix_unhash(struct sock *sk)
}
struct proto unix_dgram_proto = {
- .name = "UNIX-DGRAM",
+ .name = "UNIX",
.owner = THIS_MODULE,
.obj_size = sizeof(struct unix_sock),
.close = unix_close,
base-commit: 9e1ff307c779ce1f0f810c7ecce3d95bbae40896
--
https://chromeos.dev
Powered by blists - more mailing lists