lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 2 Nov 2021 16:08:52 +0000
From:   Saeed Mahameed <saeedm@...dia.com>
To:     "kuba@...nel.org" <kuba@...nel.org>,
        "davem@...emloft.net" <davem@...emloft.net>
CC:     "mkubecek@...e.cz" <mkubecek@...e.cz>,
        "netdev@...r.kernel.org" <netdev@...r.kernel.org>,
        "andrew@...n.ch" <andrew@...n.ch>
Subject: Re: [PATCH net] ethtool: fix ethtool msg len calculation for pause
 stats

On Mon, 2021-11-01 at 21:21 -0700, Jakub Kicinski wrote:
> ETHTOOL_A_PAUSE_STAT_MAX is the MAX attribute id,
> so we need to subtract non-stats and add one to
> get a count (IOW -2+1 == -1).
> 
> Otherwise we'll see:
> 
>   ethnl cmd 21: calculated reply length 40, but consumed 52
> 
> Fixes: 9a27a33027f2 ("ethtool: add standard pause stats")
> Signed-off-by: Jakub Kicinski <kuba@...nel.org>

Reviewed-by: Saeed Mahameed <saeedm@...dia.com>

> ---
>  net/ethtool/pause.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/net/ethtool/pause.c b/net/ethtool/pause.c
> index 9009f412151e..c9171234130b 100644
> --- a/net/ethtool/pause.c
> +++ b/net/ethtool/pause.c
> @@ -57,7 +57,7 @@ static int pause_reply_size(const struct
> ethnl_req_info *req_base,
>         if (req_base->flags & ETHTOOL_FLAG_STATS)
>                 n += nla_total_size(0) +        /* _PAUSE_STATS */
>                         nla_total_size_64bit(sizeof(u64)) *
> -                               (ETHTOOL_A_PAUSE_STAT_MAX - 2);
> +                               (ETHTOOL_A_PAUSE_STAT_MAX - 1);

Maybe for net-next we can improve readability here.
Just by staring at these lines, you'd think that this should've been
(ETHTOOL_A_PAUSE_STAT_MAX + 1), or even better, just
(ETHTOOL_A_PAUSE_STAT_CNT) /* Count of only stats */

maybe we need to separate stats from non-stats, or define
ETHTOOL_A_PAUSE_STAT_CNT where it needs to be defined.

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ