[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <0c3acbd4-6ab2-5cc5-6293-54e30093cce2@kernel.org>
Date: Thu, 4 Nov 2021 10:38:03 +0100
From: Jiri Slaby <jirislaby@...nel.org>
To: davidcomponentone@...il.com
Cc: mickflemm@...il.com, mcgrof@...nel.org, kvalo@...eaurora.org,
davem@...emloft.net, kuba@...nel.org,
linux-wireless@...r.kernel.org, netdev@...r.kernel.org,
linux-kernel@...r.kernel.org, Yang Guang <yang.guang5@....com.cn>,
Zeal Robot <zealci@....com.cn>
Subject: Re: [PATCH] ath5k: use swap() to make code cleaner
On 04. 11. 21, 7:23, davidcomponentone@...il.com wrote:
> From: Yang Guang <yang.guang5@....com.cn>
>
> Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
> opencoding it.
Why not just use sort() instead of the double loop?
> Reported-by: Zeal Robot <zealci@....com.cn>
> Signed-off-by: Yang Guang <yang.guang5@....com.cn>
> ---
> drivers/net/wireless/ath/ath5k/phy.c | 5 +----
> 1 file changed, 1 insertion(+), 4 deletions(-)
>
> diff --git a/drivers/net/wireless/ath/ath5k/phy.c b/drivers/net/wireless/ath/ath5k/phy.c
> index 00f9e347d414..08dc12611f8d 100644
> --- a/drivers/net/wireless/ath/ath5k/phy.c
> +++ b/drivers/net/wireless/ath/ath5k/phy.c
> @@ -1562,16 +1562,13 @@ static s16
> ath5k_hw_get_median_noise_floor(struct ath5k_hw *ah)
> {
> s16 sort[ATH5K_NF_CAL_HIST_MAX];
> - s16 tmp;
> int i, j;
>
> memcpy(sort, ah->ah_nfcal_hist.nfval, sizeof(sort));
> for (i = 0; i < ATH5K_NF_CAL_HIST_MAX - 1; i++) {
> for (j = 1; j < ATH5K_NF_CAL_HIST_MAX - i; j++) {
> if (sort[j] > sort[j - 1]) {
> - tmp = sort[j];
> - sort[j] = sort[j - 1];
> - sort[j - 1] = tmp;
> + swap(sort[j], sort[j - 1]);
> }
> }
> }
>
--
js
suse labs
Powered by blists - more mailing lists