[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <88b82ae31dc54a4c8b2173487f61ffe9@AcuMS.aculab.com>
Date: Thu, 2 Dec 2021 15:06:06 +0000
From: David Laight <David.Laight@...LAB.COM>
To: 'Vladimir Oltean' <olteanv@...il.com>,
Eric Dumazet <eric.dumazet@...il.com>
CC: "David S . Miller" <davem@...emloft.net>,
Jakub Kicinski <kuba@...nel.org>,
netdev <netdev@...r.kernel.org>,
Eric Dumazet <edumazet@...gle.com>
Subject: RE: [PATCH net-next 2/2] net: optimize skb_postpull_rcsum()
From: Vladimir Oltean
> Sent: 02 December 2021 13:11
...
> > --- a/include/linux/skbuff.h
> > +++ b/include/linux/skbuff.h
> > @@ -3485,7 +3485,11 @@ __skb_postpull_rcsum(struct sk_buff *skb, const void *start, unsigned int
> len,
> > static inline void skb_postpull_rcsum(struct sk_buff *skb,
> > const void *start, unsigned int len)
> > {
> > - __skb_postpull_rcsum(skb, start, len, 0);
> > + if (skb->ip_summed == CHECKSUM_COMPLETE)
> > + skb->csum = ~csum_partial(start, len, ~skb->csum);
You can't do that, the domain is 1..0xffff (or maybe 0xffffffff).
The invert has to convert ~0 to ~0 not zero.
...
> There seems to be a disparity when the skb->csum is calculated by
> skb_postpull_rcsum as zero. Before, it was calculated as 0xffff.
Which is what that will do for some inputs at least.
Maybe:
skb->csum = 1 + ~csum_partial(start, len, ~skb->csum + 1);
is right.
I think that is the same as:
skb->csum = -csum_partial(start, len, -skb->csum);
Although letting the compiler do that transform probably makes
the code easier to read.
David
-
Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK
Registration No: 1397386 (Wales)
Powered by blists - more mailing lists