[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20220110214448.rp4pcjlaqbjlggvj@pengutronix.de>
Date: Mon, 10 Jan 2022 22:44:48 +0100
From: Uwe Kleine-König <u.kleine-koenig@...gutronix.de>
To: Andy Shevchenko <andriy.shevchenko@...ux.intel.com>
Cc: Andrew Lunn <andrew@...n.ch>, Ulf Hansson <ulf.hansson@...aro.org>,
Vignesh Raghavendra <vigneshr@...com>, kvm@...r.kernel.org,
"Rafael J. Wysocki" <rafael@...nel.org>, linux-iio@...r.kernel.org,
Linus Walleij <linus.walleij@...aro.org>,
Amit Kucheria <amitk@...nel.org>, alsa-devel@...a-project.org,
Liam Girdwood <lgirdwood@...il.com>,
Guenter Roeck <groeck@...omium.org>,
Thierry Reding <thierry.reding@...il.com>,
linux-mtd@...ts.infradead.org, linux-i2c@...r.kernel.org,
Miquel Raynal <miquel.raynal@...tlin.com>,
linux-phy@...ts.infradead.org, Lee Jones <lee.jones@...aro.org>,
"David S. Miller" <davem@...emloft.net>,
Khuong Dinh <khuong@...amperecomputing.com>,
Florian Fainelli <f.fainelli@...il.com>,
Matthias Schiffer <matthias.schiffer@...tq-group.com>,
Joakim Zhang <qiangqing.zhang@....com>,
Kamal Dasu <kdasu.kdev@...il.com>,
Jiri Slaby <jirislaby@...nel.org>,
Bartosz Golaszewski <brgl@...ev.pl>,
Daniel Lezcano <daniel.lezcano@...aro.org>,
Tony Luck <tony.luck@...el.com>,
Kishon Vijay Abraham I <kishon@...com>,
bcm-kernel-feedback-list@...adcom.com,
linux-serial@...r.kernel.org, Jakub Kicinski <kuba@...nel.org>,
Zhang Rui <rui.zhang@...el.com>,
platform-driver-x86@...r.kernel.org, linux-pwm@...r.kernel.org,
Robert Richter <rric@...nel.org>,
Saravanan Sekar <sravanhome@...il.com>,
Corey Minyard <minyard@....org>, linux-pm@...r.kernel.org,
Mauro Carvalho Chehab <mchehab@...nel.org>,
John Garry <john.garry@...wei.com>,
Peter Korsgaard <peter@...sgaard.com>,
William Breathitt Gray <vilhelm.gray@...il.com>,
Mark Gross <markgross@...nel.org>, linux-gpio@...r.kernel.org,
Alex Williamson <alex.williamson@...hat.com>,
Mark Brown <broonie@...nel.org>,
Borislav Petkov <bp@...en8.de>,
Eric Auger <eric.auger@...hat.com>,
Takashi Iwai <tiwai@...e.com>,
Matthias Brugger <matthias.bgg@...il.com>,
openipmi-developer@...ts.sourceforge.net,
Jaroslav Kysela <perex@...ex.cz>,
Benson Leung <bleung@...omium.org>,
Pengutronix Kernel Team <kernel@...gutronix.de>,
linux-arm-kernel@...ts.infradead.org, linux-edac@...r.kernel.org,
Sergey Shtylyov <s.shtylyov@....ru>,
Richard Weinberger <richard@....at>,
Mun Yew Tham <mun.yew.tham@...el.com>,
Hans de Goede <hdegoede@...hat.com>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
Yoshihiro Shimoda <yoshihiro.shimoda.uh@...esas.com>,
Cornelia Huck <cohuck@...hat.com>, linux-mmc@...r.kernel.org,
linux-kernel@...r.kernel.org, linux-spi@...r.kernel.org,
linux-renesas-soc@...r.kernel.org, Vinod Koul <vkoul@...nel.org>,
James Morse <james.morse@....com>,
Zha Qipeng <qipeng.zha@...el.com>,
Sebastian Reichel <sre@...nel.org>,
Niklas Söderlund <niklas.soderlund@...natech.se>,
linux-mediatek@...ts.infradead.org,
Brian Norris <computersforpeace@...il.com>,
netdev@...r.kernel.org
Subject: Re: [PATCH 1/2] platform: make platform_get_irq_optional() optional
On Mon, Jan 10, 2022 at 11:07:03PM +0200, Andy Shevchenko wrote:
> On Mon, Jan 10, 2022 at 09:10:14PM +0100, Uwe Kleine-König wrote:
> > On Mon, Jan 10, 2022 at 10:54:48PM +0300, Sergey Shtylyov wrote:
> > > This patch is based on the former Andy Shevchenko's patch:
> > >
> > > https://lore.kernel.org/lkml/20210331144526.19439-1-andriy.shevchenko@linux.intel.com/
> > >
> > > Currently platform_get_irq_optional() returns an error code even if IRQ
> > > resource simply has not been found. It prevents the callers from being
> > > error code agnostic in their error handling:
> > >
> > > ret = platform_get_irq_optional(...);
> > > if (ret < 0 && ret != -ENXIO)
> > > return ret; // respect deferred probe
> > > if (ret > 0)
> > > ...we get an IRQ...
> > >
> > > All other *_optional() APIs seem to return 0 or NULL in case an optional
> > > resource is not available. Let's follow this good example, so that the
> > > callers would look like:
> > >
> > > ret = platform_get_irq_optional(...);
> > > if (ret < 0)
> > > return ret;
> > > if (ret > 0)
> > > ...we get an IRQ...
> >
> > The difference to gpiod_get_optional (and most other *_optional) is that
> > you can use the NULL value as if it were a valid GPIO.
>
> The problem is not only there, but also in the platform_get_irq() and that
> problem is called vIRQ0. Or as Linus put it "_cookie_" for IRQ, which never
> ever should be 0.
IMHO it's best to avoid yielding zero for a value that should be
interpreted as an (virtual) irq. Then callers don't even have to
consider if it's a valid value or not.
> > As this isn't given with for irqs, I don't think changing the return
> > value has much sense. In my eyes the problem with platform_get_irq() and
> > platform_get_irq_optional() is that someone considered it was a good
> > idea that a global function emits an error message. The problem is,
> > that's only true most of the time. (Sometimes the caller can handle an
> > error (here: the absence of an irq) just fine, sometimes the generic
> > error message just isn't as good as a message by the caller could be.
> > (here: The caller could emit "TX irq not found" which is a much nicer
> > message than "IRQ index 5 not found".)
> >
> > My suggestion would be to keep the return value of
> > platform_get_irq_optional() as is, but rename it to
> > platform_get_irq_silent() to get rid of the expectation invoked by the
> > naming similarity that motivated you to change
> > platform_get_irq_optional().
>
> This won't fix the issue with vIRQ0.
Is the patch about vIRQ0, or did you only start to consider it when I
said that for gpio NULL is a dummy value? If the former, the commit log
should better mention that.
Anyhow, I still think renaming platform_get_irq_optional() to
platform_get_irq_silent() is a good idea and the patches in this thread
are not.
Best regards
Uwe
--
Pengutronix e.K. | Uwe Kleine-König |
Industrial Linux Solutions | https://www.pengutronix.de/ |
Download attachment "signature.asc" of type "application/pgp-signature" (489 bytes)
Powered by blists - more mailing lists