[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAEf4BzZNHHKkOS=bXmKevStq-8hwm58mTz_tnMFs0vETL_z8LQ@mail.gmail.com>
Date: Fri, 11 Feb 2022 16:42:47 -0800
From: Andrii Nakryiko <andrii.nakryiko@...il.com>
To: Mauricio Vásquez <mauricio@...volk.io>
Cc: Networking <netdev@...r.kernel.org>, bpf <bpf@...r.kernel.org>,
Alexei Starovoitov <ast@...nel.org>,
Daniel Borkmann <daniel@...earbox.net>,
Andrii Nakryiko <andrii@...nel.org>,
Quentin Monnet <quentin@...valent.com>,
Rafael David Tinoco <rafaeldtinoco@...il.com>,
Lorenzo Fontana <lorenzo.fontana@...stic.co>,
Leonardo Di Donato <leonardo.didonato@...stic.co>
Subject: Re: [PATCH bpf-next v6 7/7] selftests/bpf: Test "bpftool gen min_core_btf"
On Wed, Feb 9, 2022 at 2:27 PM Mauricio Vásquez <mauricio@...volk.io> wrote:
>
> This commit reuses the core_reloc test to check if the BTF files
> generated with "bpftool gen min_core_btf" are correct. This introduces
> test_core_btfgen() that runs all the core_reloc tests, but this time
> the source BTF files are generated by using "bpftool gen min_core_btf".
>
> The goal of this test is to check that the generated files are usable,
> and not to check if the algorithm is creating an optimized BTF file.
>
> Signed-off-by: Mauricio Vásquez <mauricio@...volk.io>
> Signed-off-by: Rafael David Tinoco <rafael.tinoco@...asec.com>
> Signed-off-by: Lorenzo Fontana <lorenzo.fontana@...stic.co>
> Signed-off-by: Leonardo Di Donato <leonardo.didonato@...stic.co>
> ---
> .../selftests/bpf/prog_tests/core_reloc.c | 46 ++++++++++++++++++-
> 1 file changed, 45 insertions(+), 1 deletion(-)
>
> diff --git a/tools/testing/selftests/bpf/prog_tests/core_reloc.c b/tools/testing/selftests/bpf/prog_tests/core_reloc.c
> index b8bdd1c3efca..10a1d5fb788e 100644
> --- a/tools/testing/selftests/bpf/prog_tests/core_reloc.c
> +++ b/tools/testing/selftests/bpf/prog_tests/core_reloc.c
> @@ -2,6 +2,7 @@
> #include <test_progs.h>
> #include "progs/core_reloc_types.h"
> #include "bpf_testmod/bpf_testmod.h"
> +#include <linux/limits.h>
> #include <sys/mman.h>
> #include <sys/syscall.h>
> #include <bpf/btf.h>
> @@ -354,6 +355,8 @@ static int duration = 0;
> .fails = true, \
> }
>
> +#define BTFGEN_BTF_PATH "/tmp/btfgen.btf"
let's not use fixed file path, better use mkstemp() to create
temporary file (see core_autosize.c for an example)
> +
> struct core_reloc_test_case;
>
> typedef int (*setup_test_fn)(struct core_reloc_test_case *test);
> @@ -836,7 +839,21 @@ static size_t roundup_page(size_t sz)
> return (sz + page_size - 1) / page_size * page_size;
> }
>
> -void test_core_reloc(void)
> +static int run_btfgen(const char *src_btf, const char *dst_btf, const char *objpath)
> +{
> + char command[4096];
> + int n;
> +
> + n = snprintf(command, sizeof(command),
> + "./tools/build/bpftool/bpftool gen min_core_btf %s %s %s",
> + src_btf, dst_btf, objpath);
> + if (n < 0 || n >= sizeof(command))
> + return -1;
> +
> + return system(command);
> +}
> +
> +static void _test_core_reloc(bool btfgen)
ugh, please don't do leading underscore. Call it
"run_core_reloc_tests" or whatever, it's easy.
another naming nit (I did get confused for a second because of this):
use_btfgen, otherwise below in the code my first guess was that
"btfgen" is actually a path to bpftool or something like that
> {
> const size_t mmap_sz = roundup_page(sizeof(struct data));
> DECLARE_LIBBPF_OPTS(bpf_object_open_opts, open_opts);
> @@ -863,6 +880,22 @@ void test_core_reloc(void)
> continue;
> }
>
> + /* generate a "minimal" BTF file and use it as source */
> + if (btfgen) {
> + if (!test_case->btf_src_file || test_case->fails) {
> + test__skip();
> + continue;
> + }
> +
> + unlink(BTFGEN_BTF_PATH);
> + err = run_btfgen(test_case->btf_src_file, BTFGEN_BTF_PATH,
> + test_case->bpf_obj_file);
> + if (!ASSERT_OK(err, "run_btfgen"))
> + goto cleanup;
> +
> + test_case->btf_src_file = BTFGEN_BTF_PATH;
> + }
> +
> if (test_case->setup) {
> err = test_case->setup(test_case);
> if (CHECK(err, "test_setup", "test #%d setup failed: %d\n", i, err))
> @@ -954,8 +987,19 @@ void test_core_reloc(void)
> CHECK_FAIL(munmap(mmap_data, mmap_sz));
> mmap_data = NULL;
> }
> + unlink(BTFGEN_BTF_PATH);
> bpf_link__destroy(link);
> link = NULL;
> bpf_object__close(obj);
> }
> }
> +
> +void test_core_reloc(void)
> +{
> + _test_core_reloc(false);
> +}
> +
> +void test_core_btfgen(void)
> +{
> + _test_core_reloc(true);
> +}
> --
> 2.25.1
>
Powered by blists - more mailing lists