[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <91301fc3-e121-8f73-700b-323f7a9f4706@kernel.org>
Date: Tue, 15 Feb 2022 06:52:03 +0100
From: Jiri Slaby <jirislaby@...nel.org>
To: davidcomponentone@...il.com
Cc: mickflemm@...il.com, mcgrof@...nel.org, kvalo@...nel.org,
davem@...emloft.net, kuba@...nel.org,
linux-wireless@...r.kernel.org, netdev@...r.kernel.org,
linux-kernel@...r.kernel.org, Yang Guang <yang.guang5@....com.cn>,
Zeal Robot <zealci@....com.cn>
Subject: Re: [PATCH v2] ath5k: use swap() to make code cleaner
On 15. 02. 22, 3:31, davidcomponentone@...il.com wrote:
> From: Yang Guang <yang.guang5@....com.cn>
>
> Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
> opencoding it.
Ah, v2 already. Why do people tend to send versions of patches in an
hours interval? The comment from before few minutes on v1 still holds:
> Why don't you include that file then?
And also I commented on this very same patch sent on Nov 4 2021 (you did
it correctly on the first attempt back then) [1]:
> Why not just use sort() instead of the double loop?
So you even skip reviewers' comments. Not good.
[1]
https://lore.kernel.org/all/0c3acbd4-6ab2-5cc5-6293-54e30093cce2@kernel.org/
> Reported-by: Zeal Robot <zealci@....com.cn>
The mailbox does not seem to exist:
550 5.1.1 User unknown id=620B3CA9.000
So it's pointless to put it here to bother everyone with undeliverable
e-mails.
> Signed-off-by: Yang Guang <yang.guang5@....com.cn>
> Signed-off-by: David Yang <davidcomponentone@...il.com>
> ---
> Changes from v1->v2:
> - Fix the typo "sort" to "swap"
>
> ---
> drivers/net/wireless/ath/ath5k/phy.c | 5 +----
> 1 file changed, 1 insertion(+), 4 deletions(-)
>
> diff --git a/drivers/net/wireless/ath/ath5k/phy.c b/drivers/net/wireless/ath/ath5k/phy.c
> index 00f9e347d414..08dc12611f8d 100644
> --- a/drivers/net/wireless/ath/ath5k/phy.c
> +++ b/drivers/net/wireless/ath/ath5k/phy.c
> @@ -1562,16 +1562,13 @@ static s16
> ath5k_hw_get_median_noise_floor(struct ath5k_hw *ah)
> {
> s16 sort[ATH5K_NF_CAL_HIST_MAX];
> - s16 tmp;
> int i, j;
>
> memcpy(sort, ah->ah_nfcal_hist.nfval, sizeof(sort));
> for (i = 0; i < ATH5K_NF_CAL_HIST_MAX - 1; i++) {
> for (j = 1; j < ATH5K_NF_CAL_HIST_MAX - i; j++) {
> if (sort[j] > sort[j - 1]) {
> - tmp = sort[j];
> - sort[j] = sort[j - 1];
> - sort[j - 1] = tmp;
> + swap(sort[j], sort[j - 1]);
> }
> }
> }
Curly braces not needed now.
regards,
--
js
suse labs
Powered by blists - more mailing lists