lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Thu, 24 Mar 2022 18:03:31 -0700
From:   Jakub Kicinski <>
To:     Jian Shen <>
Cc:     <>, <>, <>,
        <>, <>,
        <>, <>, <>,
        <>, <>
Subject: Re: [RFCv5 PATCH net-next 01/20] net: rename net_device->features
 to net_device->active_features

On Thu, 24 Mar 2022 17:58:32 -0700 Jakub Kicinski wrote:
> On Thu, 24 Mar 2022 23:49:13 +0800 Jian Shen wrote:
> > The net_device->features indicates the active features of the
> > net device, rename it to active_features, make it esaier to
> > define feature helpers.  
> This breaks the build.

I see you mention that the work is not complete in the cover letter.
Either way this patch seems unnecessary, you can call the helpers
for "active" features like you do, but don't start by renaming the
existing field. The patch will be enormous.

Powered by blists - more mailing lists