lists.openwall.net | lists / announce owl-users owl-dev john-users john-dev passwdqc-users yescrypt popa3d-users / oss-security kernel-hardening musl sabotage tlsify passwords / crypt-dev xvendor / Bugtraq Full-Disclosure linux-kernel linux-netdev linux-ext4 linux-hardening linux-cve-announce PHC | |
Open Source and information security mailing list archives
| ||
|
Message-ID: <CAKwvOdnNqHOvFSqzhS+0wrPfKVvrz2VymAkZatyFTBwRsQtQnw@mail.gmail.com> Date: Tue, 29 Mar 2022 16:12:55 -0700 From: Nick Desaulniers <ndesaulniers@...gle.com> To: Jakub Kicinski <kuba@...nel.org> Cc: Jon Maloy <jmaloy@...hat.com>, Ying Xue <ying.xue@...driver.com>, Arnd Bergmann <arnd@...db.de>, Masahiro Yamada <masahiroy@...nel.org>, David Howells <dhowells@...hat.com>, Nathan Chancellor <nathan@...nel.org>, netdev@...r.kernel.org, tipc-discussion@...ts.sourceforge.net, linux-kernel@...r.kernel.org, llvm@...ts.linux.dev, Linus Torvalds <torvalds@...ux-foundation.org> Subject: Re: [PATCH v2] net, uapi: remove inclusion of arpa/inet.h On Tue, Mar 29, 2022 at 4:01 PM Jakub Kicinski <kuba@...nel.org> wrote: > > On Tue, 29 Mar 2022 15:39:56 -0700 Nick Desaulniers wrote: > > Testing out CONFIG_UAPI_HEADER_TEST=y with a prebuilt Bionic sysroot > > from Android's SDK, I encountered an error: > > > > HDRTEST usr/include/linux/fsi.h > > In file included from <built-in>:1: > > In file included from ./usr/include/linux/tipc_config.h:46: > > prebuilts/ndk/toolchains/llvm/prebuilt/linux-x86_64/sysroot/usr/include/arpa/inet.h:39:1: > > error: unknown type name 'in_addr_t' > > in_addr_t inet_addr(const char* __s); > > ^ > > > > This is because Bionic has a bug in its inclusion chain. I sent a patch > > to fix that, but looking closer at include/uapi/linux/tipc_config.h, > > there's a comment that it includes arpa/inet.h for ntohs; > > but ntohs is not defined in any UAPI header. For now, reuse the > > definitions from include/linux/byteorder/generic.h, since the various > > conversion functions do exist in UAPI headers: > > include/uapi/linux/byteorder/big_endian.h > > include/uapi/linux/byteorder/little_endian.h > > > > Link: https://android-review.googlesource.com/c/platform/bionic/+/2048127 > > Signed-off-by: Nick Desaulniers <ndesaulniers@...gle.com> > > --- > > include/uapi/linux/tipc_config.h | 32 ++++++++++++++++---------------- > > 1 file changed, 16 insertions(+), 16 deletions(-) > > > > diff --git a/include/uapi/linux/tipc_config.h b/include/uapi/linux/tipc_config.h > > index 4dfc05651c98..2c494b7ae008 100644 > > --- a/include/uapi/linux/tipc_config.h > > +++ b/include/uapi/linux/tipc_config.h > > @@ -43,10 +43,6 @@ > > #include <linux/tipc.h> > > #include <asm/byteorder.h> > > > > -#ifndef __KERNEL__ > > -#include <arpa/inet.h> /* for ntohs etc. */ > > -#endif > > Hm, how do we know no user space depends on this include? Without the ability to scan all source code in existence, I guess I can't prove or disprove that either way. If this is a reference to "thou shall not break userspace," I don't think that was in reference to UAPI headers, libc's, or inclusion chains. Worst case, someone might have to #include <arpa/inet.h> if they were relying on transitive dependencies from <linux/tipc_config.h>. I don't think we should be helping people write bad code with such transitive dependencies though. > > If nobody screams at us we can try, but then it needs to go into -next, > and net-next is closed ATM, you'll need to repost once the merge window > is over. Ack. > > > /* > > * Configuration > > * > > @@ -257,6 +253,10 @@ struct tlv_desc { > > #define TLV_SPACE(datalen) (TLV_ALIGN(TLV_LENGTH(datalen))) > > #define TLV_DATA(tlv) ((void *)((char *)(tlv) + TLV_LENGTH(0))) > > > > +#define __htonl(x) __cpu_to_be32(x) > > +#define __htons(x) __cpu_to_be16(x) > > +#define __ntohs(x) __be16_to_cpu(x) > > + > > static inline int TLV_OK(const void *tlv, __u16 space) > > { > > /* > > @@ -269,33 +269,33 @@ static inline int TLV_OK(const void *tlv, __u16 space) > > */ > > > > return (space >= TLV_SPACE(0)) && > > - (ntohs(((struct tlv_desc *)tlv)->tlv_len) <= space); > > + (__ntohs(((struct tlv_desc *)tlv)->tlv_len) <= space); > > Also why add the defines / macros? > We could switch to __cpu_to_be16() etc. directly, it seems. Sure, I thought they might be more readable, but whatever you all prefer. Will send a v3 once the merge window closes. -- Thanks, ~Nick Desaulniers
Powered by blists - more mailing lists