lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Tue, 5 Apr 2022 16:28:37 -0700
From:   Andrii Nakryiko <andrii.nakryiko@...il.com>
To:     Yuntao Wang <ytcoode@...il.com>
Cc:     Andrii Nakryiko <andrii@...nel.org>,
        Alexei Starovoitov <ast@...nel.org>, bpf <bpf@...r.kernel.org>,
        Daniel Borkmann <daniel@...earbox.net>,
        john fastabend <john.fastabend@...il.com>,
        Martin Lau <kafai@...com>, KP Singh <kpsingh@...nel.org>,
        open list <linux-kernel@...r.kernel.org>,
        "open list:KERNEL SELFTEST FRAMEWORK" 
        <linux-kselftest@...r.kernel.org>,
        Networking <netdev@...r.kernel.org>,
        Shuah Khan <shuah@...nel.org>,
        Song Liu <songliubraving@...com>, Yonghong Song <yhs@...com>
Subject: Re: [PATCH bpf-next v2] selftests/bpf: Fix issues in parse_num_list()

On Mon, Apr 4, 2022 at 11:24 PM Yuntao Wang <ytcoode@...il.com> wrote:
>
> There are some issues in parse_num_list():
>
> First, the end variable is assigned twice when parsing_end is true, it is
> unnecessary.
>
> Second, the function does not check that parsing_end is false after parsing
> argument. Thus, if the final part of the argument is something like '4-',
> parse_num_list() will discard it instead of returning -EINVAL.
>
> Clean up parse_num_list() and fix these issues.
>
> Before:
>
>  $ ./test_progs -n 2,4-
>  #2 atomic_bounds:OK
>  Summary: 1/0 PASSED, 0 SKIPPED, 0 FAILED
>
> After:
>
>  $ ./test_progs -n 2,4-
>  Failed to parse test numbers.
>
> Signed-off-by: Yuntao Wang <ytcoode@...il.com>
> ---
> v1 -> v2: add more details to commit message
>
>  tools/testing/selftests/bpf/testing_helpers.c | 18 +++++++++---------
>  1 file changed, 9 insertions(+), 9 deletions(-)
>
> diff --git a/tools/testing/selftests/bpf/testing_helpers.c b/tools/testing/selftests/bpf/testing_helpers.c
> index 795b6798ccee..82f0e2d99c23 100644
> --- a/tools/testing/selftests/bpf/testing_helpers.c
> +++ b/tools/testing/selftests/bpf/testing_helpers.c
> @@ -20,16 +20,16 @@ int parse_num_list(const char *s, bool **num_set, int *num_set_len)
>                 if (errno)
>                         return -errno;
>
> -               if (parsing_end)
> -                       end = num;
> -               else
> +               if (!parsing_end) {
>                         start = num;
> +                       if (*next == '-') {
> +                               s = next + 1;
> +                               parsing_end = true;
> +                               continue;
> +                       }
> +               }
>
> -               if (!parsing_end && *next == '-') {
> -                       s = next + 1;
> -                       parsing_end = true;
> -                       continue;
> -               } else if (*next == ',') {

I think the new structure of the code is actually harder to follow and
there is no need to change this code in the first place just to
optimize away parsing_end assignmet.

> +               if (*next == ',') {
>                         parsing_end = false;
>                         s = next + 1;
>                         end = num;
> @@ -60,7 +60,7 @@ int parse_num_list(const char *s, bool **num_set, int *num_set_len)
>                         set[i] = true;
>         }
>
> -       if (!set)
> +       if (!set || parsing_end)
>                 return -EINVAL;
>

this is a real fix, please submit just and drop the first part of the patch

>         *num_set = set;
> --
> 2.35.1
>

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ