lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Fri, 29 Apr 2022 16:38:02 -0300
From:   "Guilherme G. Piccoli" <>
To:     Xiaoming Ni <>,,,,
Cc:,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,, Arjan van de Ven <>,
        Cong Wang <>,
        Sebastian Andrzej Siewior <>,
        Valentin Schneider <>
Subject: Re: [PATCH 18/30] notifier: Show function names on notifier routines

On 27/04/2022 22:01, Xiaoming Ni wrote:
> [...]
> Duplicate Code.
> Is it better to use __func__ and %pS?
> pr_info("%s: %pS\n", __func__, n->notifier_call);

This is a great suggestion Xiaoming, much appreciated!
I feel like reinventing the wheel here - with your idea, code was super
clear and concise, very nice suggestion!!

The only 2 things that diverge from your idea: I'm using '%ps' (not
showing offsets) and also, kept the wording "(un)registered/calling",
not using __func__ - I feel it's a bit odd in the output.
OK for you?

I'm definitely using your idea in V2 heh


Powered by blists - more mailing lists