lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Date:   Wed, 22 Jun 2022 14:34:12 +0530
From:   Arun Ramadoss <arun.ramadoss@...rochip.com>
To:     <linux-kernel@...r.kernel.org>, <netdev@...r.kernel.org>
CC:     Woojung Huh <woojung.huh@...rochip.com>,
        <UNGLinuxDriver@...rochip.com>, Andrew Lunn <andrew@...n.ch>,
        Vivien Didelot <vivien.didelot@...il.com>,
        Florian Fainelli <f.fainelli@...il.com>,
        Vladimir Oltean <olteanv@...il.com>,
        "David S. Miller" <davem@...emloft.net>,
        Eric Dumazet <edumazet@...gle.com>,
        Jakub Kicinski <kuba@...nel.org>,
        Paolo Abeni <pabeni@...hat.com>,
        "Russell King" <linux@...linux.org.uk>
Subject: [Patch net-next 00/13] net: dsa: microchip: common spi probe for the ksz series switches - part 2

This patch series aims to refactor the ksz_switch_register routine to have the
common flow for the ksz series switch. And this is the follow up patch series.

First, it tries moves the common implementation in the setup from individual
files to ksz_setup. Then implements the common dsa_switch_ops structure instead
of independent registration. And then moves the ksz_dev_ops to ksz_common.c,
it allows the dynamic detection of which ksz_dev_ops to be used based on
the switch detection function.

Finally, the patch updates the ksz_spi probe function to be same for all the
ksz_switches.

Arun Ramadoss (13):
  net: dsa: microchip: rename shutdown to reset in ksz_dev_ops
  net: dsa: microchip: add config_cpu_port to struct ksz_dev_ops
  net: dsa: microchip: add the enable_stp_addr pointer in ksz_dev_ops
  net: dsa: microchip: move setup function to ksz_common
  net: dsa: microchip: move broadcast rate limit to ksz_setup
  net: dsa: microchip: move multicast enable to ksz_setup
  net: dsa: microchip: move start of switch to ksz_setup
  net: dsa: microchip: common dsa_switch_ops for ksz switches
  net: dsa: microchip: ksz9477: separate phylink mode from switch
    register
  net: dsa: microchip: common menuconfig for ksz series switch
  net: dsa: microchip: move ksz_dev_ops to ksz_common.c
  net: dsa: microchip: remove the ksz8/ksz9477_switch_register
  net: dsa: microchip: common ksz_spi_probe for ksz switches

 drivers/net/dsa/microchip/Kconfig             |  42 +--
 drivers/net/dsa/microchip/Makefile            |  10 +-
 drivers/net/dsa/microchip/ksz8.h              |  48 +++
 drivers/net/dsa/microchip/ksz8795.c           | 195 +++--------
 drivers/net/dsa/microchip/ksz8795_reg.h       |  12 -
 drivers/net/dsa/microchip/ksz8863_smi.c       |   2 +-
 drivers/net/dsa/microchip/ksz9477.c           | 244 +++++--------
 drivers/net/dsa/microchip/ksz9477.h           |  60 ++++
 drivers/net/dsa/microchip/ksz9477_i2c.c       |   6 +-
 drivers/net/dsa/microchip/ksz9477_reg.h       |  12 -
 drivers/net/dsa/microchip/ksz9477_spi.c       | 150 --------
 drivers/net/dsa/microchip/ksz_common.c        | 326 +++++++++++++-----
 drivers/net/dsa/microchip/ksz_common.h        |  82 ++---
 .../microchip/{ksz8795_spi.c => ksz_spi.c}    |  89 +++--
 14 files changed, 598 insertions(+), 680 deletions(-)
 create mode 100644 drivers/net/dsa/microchip/ksz9477.h
 delete mode 100644 drivers/net/dsa/microchip/ksz9477_spi.c
 rename drivers/net/dsa/microchip/{ksz8795_spi.c => ksz_spi.c} (60%)


base-commit: 8720bd951b8e8515ffd995c7631790fdabaa9265
-- 
2.36.1

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ