[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20220715060457.GA2928@cloud-MacBookPro>
Date: Thu, 14 Jul 2022 23:04:57 -0700
From: binyi <dantengknight@...il.com>
To: Joe Perches <joe@...ches.com>,
Dan Carpenter <dan.carpenter@...cle.com>
Cc: Manish Chopra <manishc@...vell.com>, GR-Linux-NIC-Dev@...vell.com,
Coiby Xu <coiby.xu@...il.com>,
Greg Kroah-Hartman <gregkh@...uxfoundation.org>,
netdev@...r.kernel.org, linux-staging@...ts.linux.dev,
linux-kernel@...r.kernel.org
Subject: Re: [PATCH v3] staging: qlge: Fix indentation issue under long for
loop
On Tue, Jul 12, 2022 at 07:14:55AM -0700, Joe Perches wrote:
> On Tue, 2022-07-12 at 16:46 +0300, Dan Carpenter wrote:
> > On Sun, Jul 10, 2022 at 02:04:18PM -0700, Binyi Han wrote:
> > > Fix indentation issue to adhere to Linux kernel coding style,
> > > Issue found by checkpatch. Change the long for loop into 3 lines. And
> > > optimize by avoiding the multiplication.
> >
> > There is no possible way this optimization helps benchmarks. Better to
> > focus on readability.
>
> I think removing the multiply _improves_ readability.
>
> > > diff --git a/drivers/staging/qlge/qlge_main.c b/drivers/staging/qlge/qlge_main.c
> []
> > > @@ -3007,10 +3007,12 @@ static int qlge_start_rx_ring(struct qlge_adapter *qdev, struct rx_ring *rx_ring
> > > tmp = (u64)rx_ring->lbq.base_dma;
> > > base_indirect_ptr = rx_ring->lbq.base_indirect;
> > >
> > > - for (page_entries = 0; page_entries <
> > > - MAX_DB_PAGES_PER_BQ(QLGE_BQ_LEN); page_entries++)
> > > - base_indirect_ptr[page_entries] =
> > > - cpu_to_le64(tmp + (page_entries * DB_PAGE_SIZE));
> > > + for (page_entries = 0;
> > > + page_entries < MAX_DB_PAGES_PER_BQ(QLGE_BQ_LEN);
> > > + page_entries++) {
> > > + base_indirect_ptr[page_entries] = cpu_to_le64(tmp);
> > > + tmp += DB_PAGE_SIZE;
> >
> > I've previously said that using "int i;" is clearer here. You would
> > kind of expect "page_entries" to be the number of entries, so it's kind
> > of misleading. In other words, it's not just harmless wordiness and
> > needless exposition, it's actively bad.
>
> Likely true.
>
I agree it could be misleading. But if "page_entries" is in the for loop I
would assume it's some kind of index variable, and still it provides some
information (page entry) for the index, probably page_entry_idx could be
better name but still makes the for loop a very long one. I guess I would
leave it be.
> > I would probably just put it on one line:
> >
> > for (i = 0; i MAX_DB_PAGES_PER_BQ(QLGE_BQ_LEN); i++)
> > base_indirect_ptr[i] = cpu_to_le64(tmp + (i * DB_PAGE_SIZE));
> >
> > But if you want to break it up you could do:
> >
> > for (i = 0; i MAX_DB_PAGES_PER_BQ(QLGE_BQ_LEN); i++)
> > base_indirect_ptr[i] = cpu_to_le64(tmp +
> > (i * DB_PAGE_SIZE));
> >
> > "tmp" is kind of a bad name. Also "base_indirect_ptr" would be better
> > as "base_indirect".
>
> tmp is a poor name here. Maybe dma would be better.
>
Yeah, I think so.
> MAX_DB_PAGES_PER_BQ(QLGE_BQ_LEN) is also a poorly named macro
> where all the existing uses are QLGE_BQ_LEN.
>
> And there's base_indirect_ptr and base_indirect_dma in the struct
> so just base_indirect might not be the best.
>
> tmp = (u64)rx_ring->lbq.base_dma;
> base_indirect_ptr = rx_ring->lbq.base_indirect;
>
> And clarity is good.
> Though here, clarity to value for effort though is dubious.
>
> btw: this code got moved to staging 3 years ago.
>
> Maybe it's getting closer to removal time.
>
That sounds sad.
Thank you for reviewing!
Best,
Binyi
Powered by blists - more mailing lists