[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20220727064321.2953971-1-mw@semihalf.com>
Date: Wed, 27 Jul 2022 08:43:13 +0200
From: Marcin Wojtas <mw@...ihalf.com>
To: linux-kernel@...r.kernel.org, linux-acpi@...r.kernel.org,
netdev@...r.kernel.org
Cc: rafael@...nel.org, andriy.shevchenko@...ux.intel.com,
sean.wang@...iatek.com, Landen.Chao@...iatek.com,
linus.walleij@...aro.org, andrew@...n.ch, vivien.didelot@...il.com,
f.fainelli@...il.com, olteanv@...il.com, davem@...emloft.net,
edumazet@...gle.com, kuba@...nel.org, pabeni@...hat.com,
linux@...linux.org.uk, hkallweit1@...il.com, gjb@...ihalf.com,
mw@...ihalf.com, jaz@...ihalf.com, tn@...ihalf.com,
Samer.El-Haj-Mahmoud@....com, upstream@...ihalf.com
Subject: [net-next: PATCH v3 0/8] DSA: switch to fwnode_/device_
Hi,
This is a re-spin of the DSA migration to fwnode_/device_ API.
It addresses all comments from the previous iteration - the
details are summarized in the changelog section below.
This time the patchset is based and tested on top of
pure net-next/main branch. Each commit was checked on:
* On EspressoBIN
* On SolidRun CN913x CEx7 Eval Board
Any comments or remarks will be appreciated.
Best regards,
Marcin
Changelog v2 -> v3:
1/8:
* Replace forward declaration s/device_node/fwnode_handle/ in
include/linux/phy_fixed.h
* Add Florian's RB
* 3/8:
* Extend lines width in the commit message.
* While dropping dp->dn fields in the drivers, switch to
fwnode_ API in the updated places.
* 5/8:
* Update routine name to fwnode_find_parent_dev_match()
* Improve comment section
* Move the definition adjacent to a group of fwnode
APIs operating on parents
Changelog v1 -> v2:
1/8
* Drop unnecessary check in fixed_phy_get_gpiod()
* Improve line breaking
* Use device_set_node & dev_fwnode
2/8
* Switch to fwnode_property_count_u32 and fix comparison
in if statement.
3/8
* Drop dn usage entirely and use dp->fwnode only. Update
all dependent drivers to use to_of_node.
* Use device_set_node, dev_fwnode & device_get_named_child_node
* Replace '_of' routines suffix with '_fw'
4/8
* Use device_set_node
5/8
* New patch
6/8
* Use device_match_fwnode
* Restore EXPORT_SYMBOL()
7/8
* Get rid of of_mdiobus_register_device
8/8
* Use dev_fwnode in mv88e6xxx_probe
* Simplify condition checks in mv88e6xxx_probe as suggested by Andy
Marcin Wojtas (8):
net: phy: fixed_phy: switch to fwnode_ API
net: mdio: switch fixed-link PHYs API to fwnode_
net: dsa: switch to device_/fwnode_ APIs
net: mvpp2: initialize port fwnode pointer
device property: introduce fwnode_find_parent_dev_match
net: core: switch to fwnode_find_net_device_by_node()
net: mdio: introduce fwnode_mdiobus_register_device()
net: dsa: mv88e6xxx: switch to device_/fwnode_ APIs
include/linux/etherdevice.h | 1 +
include/linux/fwnode_mdio.h | 22 ++++
include/linux/of_net.h | 6 -
include/linux/phy_fixed.h | 6 +-
include/linux/property.h | 1 +
include/net/dsa.h | 2 +-
net/dsa/dsa_priv.h | 4 +-
drivers/base/property.c | 23 ++++
drivers/net/dsa/mt7530.c | 6 +-
drivers/net/dsa/mv88e6xxx/chip.c | 57 ++++-----
drivers/net/dsa/qca/qca8k.c | 2 +-
drivers/net/dsa/realtek/rtl8365mb.c | 2 +-
drivers/net/ethernet/marvell/mvpp2/mvpp2_main.c | 2 +-
drivers/net/mdio/fwnode_mdio.c | 129 ++++++++++++++++++++
drivers/net/mdio/of_mdio.c | 111 +----------------
drivers/net/phy/fixed_phy.c | 39 +++---
net/core/net-sysfs.c | 25 ++--
net/dsa/dsa2.c | 101 ++++++++-------
net/dsa/port.c | 68 +++++------
net/dsa/slave.c | 7 +-
20 files changed, 329 insertions(+), 285 deletions(-)
--
2.29.0
Powered by blists - more mailing lists