lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date:   Mon, 24 Oct 2022 16:45:09 +0200
From:   Geert Uytterhoeven <geert@...ux-m68k.org>
To:     biju.das.jz@...renesas.com
Cc:     Wolfgang Grandegger <wg@...ndegger.com>,
        Marc Kleine-Budde <mkl@...gutronix.de>,
        "David S. Miller" <davem@...emloft.net>,
        Eric Dumazet <edumazet@...gle.com>,
        Jakub Kicinski <kuba@...nel.org>,
        Paolo Abeni <pabeni@...hat.com>,
        Vincent Mailhol <mailhol.vincent@...adoo.fr>,
        Stefan Mätje <stefan.maetje@....eu>,
        Ulrich Hecht <uli+renesas@...nd.eu>,
        Lad Prabhakar <prabhakar.mahadev-lad.rj@...renesas.com>,
        Christophe JAILLET <christophe.jaillet@...adoo.fr>,
        linux-can@...r.kernel.org, netdev@...r.kernel.org,
        Chris Paterson <Chris.Paterson2@...esas.com>,
        Biju Das <biju.das@...renesas.com>,
        linux-renesas-soc@...r.kernel.org
Subject: Re: [PATCH 3/6] can: rcar_canfd: Add multi_global_irqs to struct rcar_canfd_hw_info

Hi Biju,

On Sat, Oct 22, 2022 at 1:03 PM Biju Das <biju.das.jz@...renesas.com> wrote:
> RZ/G2L has separate IRQ lines for receive FIFO and global error interrupt
> whereas R-Car has combined IRQ line.
>
> Add multi_global_irqs to struct rcar_canfd_hw_info to select the driver to
> choose between combined and separate irq registration for global
> interrupts.
>
> Signed-off-by: Biju Das <biju.das.jz@...renesas.com>

Thanks for your patch!

> --- a/drivers/net/can/rcar/rcar_canfd.c
> +++ b/drivers/net/can/rcar/rcar_canfd.c
> @@ -526,6 +526,8 @@ struct rcar_canfd_global;
>  struct rcar_canfd_hw_info {
>         enum rcanfd_chip_id chip_id;
>         u32 max_channels;
> +       /* hardware features */
> +       unsigned multi_global_irqs:1;   /* Has multiple global irqs  */

I'm not sure this is the best name for this flag (especially considering
the other flag being added in [5/6])...

>  };
>
>  /* Channel priv data */
> @@ -603,6 +605,7 @@ static const struct rcar_canfd_hw_info rcar_gen3_hw_info = {
>  static const struct rcar_canfd_hw_info rzg2l_hw_info = {
>         .chip_id = RENESAS_RZG2L,
>         .max_channels = 2,
> +       .multi_global_irqs = 1,
>  };
>
>  static const struct rcar_canfd_hw_info r8a779a0_hw_info = {
> @@ -1874,7 +1877,7 @@ static int rcar_canfd_probe(struct platform_device *pdev)
>                 of_node_put(of_child);
>         }
>
> -       if (info->chip_id != RENESAS_RZG2L) {
> +       if (!info->multi_global_irqs) {
>                 ch_irq = platform_get_irq_byname_optional(pdev, "ch_int");
>                 if (ch_irq < 0) {
>                         /* For backward compatibility get irq by index */
> @@ -1957,7 +1960,7 @@ static int rcar_canfd_probe(struct platform_device *pdev)
>         gpriv->base = addr;
>
>         /* Request IRQ that's common for both channels */
> -       if (info->chip_id != RENESAS_RZG2L) {
> +       if (!info->multi_global_irqs) {

All checks for this flag are negative checks.  What about inverting
the meaning of the flag, so these can become positive checks?

>                 err = devm_request_irq(&pdev->dev, ch_irq,
>                                        rcar_canfd_channel_interrupt, 0,
>                                        "canfd.ch_int", gpriv);

As the patch itself is correct:
Reviewed-by: Geert Uytterhoeven <geert+renesas@...der.be>

Gr{oetje,eeting}s,

                        Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@...ux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
                                -- Linus Torvalds

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ