[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <TYBPR01MB53414AB270D1CF061379F229D8FD9@TYBPR01MB5341.jpnprd01.prod.outlook.com>
Date: Thu, 12 Jan 2023 07:32:57 +0000
From: Yoshihiro Shimoda <yoshihiro.shimoda.uh@...esas.com>
To: "Arun.Ramadoss@...rochip.com" <Arun.Ramadoss@...rochip.com>,
"andrew@...n.ch" <andrew@...n.ch>,
"linux@...linux.org.uk" <linux@...linux.org.uk>,
"kuba@...nel.org" <kuba@...nel.org>,
"pabeni@...hat.com" <pabeni@...hat.com>,
"edumazet@...gle.com" <edumazet@...gle.com>,
"davem@...emloft.net" <davem@...emloft.net>,
"hkallweit1@...il.com" <hkallweit1@...il.com>
CC: "netdev@...r.kernel.org" <netdev@...r.kernel.org>,
"linux-renesas-soc@...r.kernel.org"
<linux-renesas-soc@...r.kernel.org>
Subject: RE: [PATCH net-next v2 2/4] net: ethernet: renesas: rswitch: Simplify
struct phy * handling
Hi Arun,
> From: Arun.Ramadoss@...rochip.com, Sent: Tuesday, January 10, 2023 11:15 PM
>
> Hi Yoshihiro,
> On Tue, 2023-01-10 at 14:02 +0900, Yoshihiro Shimoda wrote:
> > Simplify struct phy *serdes handling by keeping the valiable in
> > the struct rswitch_device.
> >
> > Signed-off-by: Yoshihiro Shimoda <yoshihiro.shimoda.uh@...esas.com>
> > ---
> > drivers/net/ethernet/renesas/rswitch.c | 40 ++++++++++++----------
> > ----
> > drivers/net/ethernet/renesas/rswitch.h | 1 +
> > 2 files changed, 19 insertions(+), 22 deletions(-)
> >
> >
> >
> > -static int rswitch_serdes_set_params(struct rswitch_device *rdev)
> >
> >
> > static int rswitch_ether_port_init_one(struct rswitch_device *rdev)
> > @@ -1299,6 +1290,10 @@ static int rswitch_ether_port_init_one(struct
> > rswitch_device *rdev)
> > if (err < 0)
> > goto err_phylink_init;
> >
> > + err = rswitch_serdes_phy_get(rdev);
> > + if (err < 0)
> > + goto err_serdes_phy_get;
>
> I think, we can use *err_serdes_set_params* instead of creating new
> label err_serdes_phy_get, since the label is not doing any work.
Thank you for your comment. However, this driver already has a similar
label and error handling like below:
---
err = rswitch_gwca_request_irqs(priv);
if (err < 0)
goto err_gwca_request_irq;
err = rswitch_gwca_hw_init(priv);
if (err < 0)
goto err_gwca_hw_init;
...
err_gwca_hw_init:
err_gwca_request_irq:
rcar_gen4_ptp_unregister(priv->ptp_priv);
---
The err_ labels are related to the functions.
So, I think keeping same function names/label names is
better for readability.
Best regards,
Yoshihiro Shimoda
> > +
> > err = rswitch_serdes_set_params(rdev);
> > if (err < 0)
> > goto err_serdes_set_params;
> > @@ -1306,6 +1301,7 @@ static int rswitch_ether_port_init_one(struct
> > rswitch_device *rdev)
> > return 0;
> >
> > err_serdes_set_params:
> > +err_serdes_phy_get:
> > rswitch_phylink_deinit(rdev);
> >
> > err_phylink_init:
> > diff --git a/drivers/net/ethernet/renesas/rswitch.h
> > b/drivers/net/ethernet/renesas/rswitch.h
> > index edbdd1b98d3d..d9a0be6666f5 100644
> > --- a/drivers/net/ethernet/renesas/rswitch.h
> > +++ b/drivers/net/ethernet/renesas/rswitch.h
> > @@ -941,6 +941,7 @@ struct rswitch_device {
> >
> > int port;
> > struct rswitch_etha *etha;
> > + struct phy *serdes;
> > };
> >
> > struct rswitch_mfwd_mac_table_entry {
Powered by blists - more mailing lists