[<prev] [next>] [day] [month] [year] [list]
Message-ID: <20230130022252.1514647-1-jaewan@google.com>
Date: Mon, 30 Jan 2023 02:22:52 +0000
From: Jaewan Kim <jaewan@...gle.com>
To: johannes@...solutions.net, linux-wireless@...r.kernel.org,
netdev@...r.kernel.org
Cc: kernel-team@...roid.com, Jaewan Kim <jaewan@...gle.com>
Subject: [PATCH] mac80211_hwsim: Rename pid to portid to avoid confusion
It is a frequent mistake to confuse the netlink port identifier with a
process identifier. Try to reduce this confusion by renaming
that hold port identifiers portid instead of pid.
This change replicates following commit:
commit 15e473046cb6 ("netlink: Rename pid to portid to avoid confusion")
Signed-off-by: Jaewan Kim <jaewan@...gle.com>
---
drivers/net/wireless/mac80211_hwsim.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/net/wireless/mac80211_hwsim.c b/drivers/net/wireless/mac80211_hwsim.c
index c57c8903b7c0..4cc4eaf80b14 100644
--- a/drivers/net/wireless/mac80211_hwsim.c
+++ b/drivers/net/wireless/mac80211_hwsim.c
@@ -2034,7 +2034,7 @@ static void mac80211_hwsim_tx_frame(struct ieee80211_hw *hw,
struct ieee80211_channel *chan)
{
struct mac80211_hwsim_data *data = hw->priv;
- u32 _pid = READ_ONCE(data->wmediumd);
+ u32 _portid = READ_ONCE(data->wmediumd);
if (ieee80211_hw_check(hw, SUPPORTS_RC_TABLE)) {
struct ieee80211_tx_info *txi = IEEE80211_SKB_CB(skb);
@@ -2045,8 +2045,8 @@ static void mac80211_hwsim_tx_frame(struct ieee80211_hw *hw,
mac80211_hwsim_monitor_rx(hw, skb, chan);
- if (_pid || hwsim_virtio_enabled)
- return mac80211_hwsim_tx_frame_nl(hw, skb, _pid, chan);
+ if (_portid || hwsim_virtio_enabled)
+ return mac80211_hwsim_tx_frame_nl(hw, skb, _portid, chan);
data->tx_pkts++;
data->tx_bytes += skb->len;
--
2.39.1.456.gfc5497dd1b-goog
Powered by blists - more mailing lists