[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <a4eea208-987d-c443-9b4e-243e785e85df@intel.com>
Date: Fri, 10 Feb 2023 11:35:10 -0800
From: Jacob Keller <jacob.e.keller@...el.com>
To: Jiri Pirko <jiri@...nulli.us>, <netdev@...r.kernel.org>
CC: <davem@...emloft.net>, <kuba@...nel.org>, <pabeni@...hat.com>,
<edumazet@...gle.com>, <tariqt@...dia.com>, <saeedm@...dia.com>,
<gal@...dia.com>, <kim.phillips@....com>, <moshe@...dia.com>,
<simon.horman@...igine.com>, <idosch@...dia.com>
Subject: Re: [patch net-next v2 3/7] devlink: fix the name of value arg of
devl_param_driverinit_value_get()
On 2/10/2023 2:01 AM, Jiri Pirko wrote:
> From: Jiri Pirko <jiri@...dia.com>
>
> Probably due to copy-paste error, the name of the arg is "init_val"
> which is misleading, as the pointer is used to point to struct where to
> store the current value. Rename it to "val" and change the arg comment
> a bit on the way.
>
> Signed-off-by: Jiri Pirko <jiri@...dia.com>
> Reviewed-by: Simon Horman <simon.horman@...igine.com>
> Acked-by: Jakub Kicinski <kuba@...nel.org>
Reviewed-by: Jacob Keller <jacob.e.keller@...el.com>
> ---
> include/net/devlink.h | 2 +-
> net/devlink/leftover.c | 7 ++++---
> 2 files changed, 5 insertions(+), 4 deletions(-)
>
> diff --git a/include/net/devlink.h b/include/net/devlink.h
> index 8ed960345f37..6a942e70e451 100644
> --- a/include/net/devlink.h
> +++ b/include/net/devlink.h
> @@ -1784,7 +1784,7 @@ void devlink_params_unregister(struct devlink *devlink,
> const struct devlink_param *params,
> size_t params_count);
> int devl_param_driverinit_value_get(struct devlink *devlink, u32 param_id,
> - union devlink_param_value *init_val);
> + union devlink_param_value *val);
> void devl_param_driverinit_value_set(struct devlink *devlink, u32 param_id,
> union devlink_param_value init_val);
> void devl_param_value_changed(struct devlink *devlink, u32 param_id);
> diff --git a/net/devlink/leftover.c b/net/devlink/leftover.c
> index 61e59556ea03..dab7326dc3ea 100644
> --- a/net/devlink/leftover.c
> +++ b/net/devlink/leftover.c
> @@ -9630,13 +9630,14 @@ EXPORT_SYMBOL_GPL(devlink_params_unregister);
> *
> * @devlink: devlink
> * @param_id: parameter ID
> - * @init_val: value of parameter in driverinit configuration mode
> + * @val: pointer to store the value of parameter in driverinit
> + * configuration mode
> *
> * This function should be used by the driver to get driverinit
> * configuration for initialization after reload command.
> */
> int devl_param_driverinit_value_get(struct devlink *devlink, u32 param_id,
> - union devlink_param_value *init_val)
> + union devlink_param_value *val)
> {
> struct devlink_param_item *param_item;
>
> @@ -9656,7 +9657,7 @@ int devl_param_driverinit_value_get(struct devlink *devlink, u32 param_id,
> DEVLINK_PARAM_CMODE_DRIVERINIT)))
> return -EOPNOTSUPP;
>
> - *init_val = param_item->driverinit_value;
> + *val = param_item->driverinit_value;
>
> return 0;
> }
Powered by blists - more mailing lists