lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [day] [month] [year] [list]
Date:   Mon, 13 Feb 2023 04:55:59 +0000
From:   Subbaraya Sundeep Bhatta <sbhatta@...vell.com>
To:     Deepak R Varma <drv@...lo.com>,
        Sunil Kovvuri Goutham <sgoutham@...vell.com>,
        Geethasowjanya Akula <gakula@...vell.com>,
        Hariprasad Kelam <hkelam@...vell.com>,
        "David S. Miller" <davem@...emloft.net>,
        Eric Dumazet <edumazet@...gle.com>,
        Jakub Kicinski <kuba@...nel.org>,
        Paolo Abeni <pabeni@...hat.com>,
        "netdev@...r.kernel.org" <netdev@...r.kernel.org>,
        "linux-kernel@...r.kernel.org" <linux-kernel@...r.kernel.org>
CC:     Saurabh Singh Sengar <ssengar@...rosoft.com>,
        Praveen Kumar <kumarpraveen@...ux.microsoft.com>
Subject: RE: [EXT] [PATCH] octeontx2-pf: Remove repeating variable in test

Hi,

> -----Original Message-----
> From: Deepak R Varma <drv@...lo.com>
> Sent: Saturday, February 11, 2023 3:16 PM
> To: Sunil Kovvuri Goutham <sgoutham@...vell.com>; Geethasowjanya Akula
> <gakula@...vell.com>; Subbaraya Sundeep Bhatta <sbhatta@...vell.com>;
> Hariprasad Kelam <hkelam@...vell.com>; David S. Miller
> <davem@...emloft.net>; Eric Dumazet <edumazet@...gle.com>; Jakub
> Kicinski <kuba@...nel.org>; Paolo Abeni <pabeni@...hat.com>;
> netdev@...r.kernel.org; linux-kernel@...r.kernel.org
> Cc: Saurabh Singh Sengar <ssengar@...rosoft.com>; Praveen Kumar
> <kumarpraveen@...ux.microsoft.com>; Deepak R Varma <drv@...lo.com>
> Subject: [EXT] [PATCH] octeontx2-pf: Remove repeating variable in test
> 
> External Email
> 
> ----------------------------------------------------------------------
> No need to & a variable with itself. Remove extra variable from the expression.
> Change allows to realign code and improve readability.
> Issue identified using doublebitand.cocci Coccinelle semantic patch.
> 
> Signed-off-by: Deepak R Varma <drv@...lo.com>
> ---
>  drivers/net/ethernet/marvell/octeontx2/nic/otx2_flows.c | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
> 
> diff --git a/drivers/net/ethernet/marvell/octeontx2/nic/otx2_flows.c
> b/drivers/net/ethernet/marvell/octeontx2/nic/otx2_flows.c
> index 684cb8ec9f21..66a27ee5ca56 100644
> --- a/drivers/net/ethernet/marvell/octeontx2/nic/otx2_flows.c
> +++ b/drivers/net/ethernet/marvell/octeontx2/nic/otx2_flows.c
> @@ -792,8 +792,7 @@ static int otx2_prepare_ipv6_flow(struct
> ethtool_rx_flow_spec *fsp,
>  		}
> 
>  		/* NPC profile doesn't extract AH/ESP header fields */
> -		if ((ah_esp_mask->spi & ah_esp_hdr->spi) ||
> -		    (ah_esp_mask->tclass & ah_esp_mask->tclass))
> +		if ((ah_esp_mask->spi & ah_esp_hdr->spi) || ah_esp_mask-
> >tclass)

It is a typo. Below is the correct one:
                           if ((ah_esp_mask->spi & ah_esp_hdr->spi) ||
		   (ah_esp_mask->tclass & ah_esp_hdr->tclass))

Thanks,
Sundeep

>  			return -EOPNOTSUPP;
> 
>  		if (flow_type == AH_V6_FLOW)
> --
> 2.34.1
> 
> 

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ