lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Wed, 24 May 2023 19:56:26 +0200
From: Oleksij Rempel <o.rempel@...gutronix.de>
To: Andrew Lunn <andrew@...n.ch>
Cc: Woojung Huh <woojung.huh@...rochip.com>,
	Arun Ramadoss <arun.ramadoss@...rochip.com>,
	Florian Fainelli <f.fainelli@...il.com>,
	"Russell King (Oracle)" <linux@...linux.org.uk>,
	netdev@...r.kernel.org, linux-kernel@...r.kernel.org,
	UNGLinuxDriver@...rochip.com, Eric Dumazet <edumazet@...gle.com>,
	Vladimir Oltean <olteanv@...il.com>, kernel@...gutronix.de,
	Jakub Kicinski <kuba@...nel.org>, Paolo Abeni <pabeni@...hat.com>,
	"David S. Miller" <davem@...emloft.net>
Subject: Re: [PATCH net-next v1 4/5] net: dsa: microchip: ksz8: Prepare
 ksz8863_smi for regmap register access validation

On Wed, May 24, 2023 at 06:59:28PM +0200, Andrew Lunn wrote:
> On Wed, May 24, 2023 at 02:32:19PM +0200, Oleksij Rempel wrote:
> > This patch prepares the ksz8863_smi part of ksz8 driver to utilize the
> > regmap register access validation feature.
> > 
> > Signed-off-by: Oleksij Rempel <o.rempel@...gutronix.de>
> > ---
> >  drivers/net/dsa/microchip/ksz8863_smi.c | 11 +++++++++++
> >  1 file changed, 11 insertions(+)
> > 
> > diff --git a/drivers/net/dsa/microchip/ksz8863_smi.c b/drivers/net/dsa/microchip/ksz8863_smi.c
> > index 2af807db0b45..303a4707c759 100644
> > --- a/drivers/net/dsa/microchip/ksz8863_smi.c
> > +++ b/drivers/net/dsa/microchip/ksz8863_smi.c
> > @@ -104,6 +104,7 @@ static const struct regmap_config ksz8863_regmap_config[] = {
> >  		.cache_type = REGCACHE_NONE,
> >  		.lock = ksz_regmap_lock,
> >  		.unlock = ksz_regmap_unlock,
> > +		.max_register = BIT(8) - 1,
> 
> Maybe SZ_256 - 1 is more readable?

It is the same way used in other regmap_config in this driver.

As for me, U8_MAX is probably more understandable way, since addressing
since is 8bit.

> >  	},
> >  	{
> >  		.name = "#16",
> > @@ -113,6 +114,7 @@ static const struct regmap_config ksz8863_regmap_config[] = {
> >  		.cache_type = REGCACHE_NONE,
> >  		.lock = ksz_regmap_lock,
> >  		.unlock = ksz_regmap_unlock,
> > +		.max_register = BIT(8) - 2,
> 
> - 2?
> 
> Is this the 16 bit regmap? So it has 1/2 the number of registers of
> the 8 bit regmap? So i would of thought it should be BIT(7)-1, or
> SZ_128-1 ?

Sorry, it is a typo.

-- 
Pengutronix e.K.                           |                             |
Steuerwalder Str. 21                       | http://www.pengutronix.de/  |
31137 Hildesheim, Germany                  | Phone: +49-5121-206917-0    |
Amtsgericht Hildesheim, HRA 2686           | Fax:   +49-5121-206917-5555 |

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ