lists.openwall.net | lists / announce owl-users owl-dev john-users john-dev passwdqc-users yescrypt popa3d-users / oss-security kernel-hardening musl sabotage tlsify passwords / crypt-dev xvendor / Bugtraq Full-Disclosure linux-kernel linux-netdev linux-ext4 linux-hardening linux-cve-announce PHC | |
Open Source and information security mailing list archives
| ||
|
Message-ID: <62beadfd-9de1-9fa8-f62f-b8eb8cf355b8@amd.com> Date: Thu, 25 May 2023 09:41:23 -0500 From: Tom Lendacky <thomas.lendacky@....com> To: Raju Rangoju <Raju.Rangoju@....com>, netdev@...r.kernel.org Cc: Sudheesh Mavila <sudheesh.mavila@....com>, Simon Horman <simon.horman@...igine.com>, Shyam Sundar S K <Shyam-sundar.S-k@....com> Subject: Re: [PATCH v2 net] amd-xgbe: fix the false linkup in xgbe_phy_status On 5/25/23 05:17, Raju Rangoju wrote: > In the event of a change in XGBE mode, the current auto-negotiation > needs to be reset and the AN cycle needs to be re-triggerred. However, > the current code ignores the return value of xgbe_set_mode(), leading to > false information as the link is declared without checking the status > register. > > Fix this by propagating the mode switch status information to > xgbe_phy_status(). > > Fixes: e57f7a3feaef ("amd-xgbe: Prepare for working with more than one type of phy") > Co-developed-by: Sudheesh Mavila <sudheesh.mavila@....com> > Signed-off-by: Sudheesh Mavila <sudheesh.mavila@....com> > Reviewed-by: Simon Horman <simon.horman@...igine.com> > Acked-by: Shyam Sundar S K <Shyam-sundar.S-k@....com> > Signed-off-by: Raju Rangoju <Raju.Rangoju@....com> > --- > Changes since v1: > - Fixed the warning "1 blamed authors not CCed" > - Fixed spelling mistake > > drivers/net/ethernet/amd/xgbe/xgbe-mdio.c | 14 ++++++++++---- > 1 file changed, 10 insertions(+), 4 deletions(-) > > diff --git a/drivers/net/ethernet/amd/xgbe/xgbe-mdio.c b/drivers/net/ethernet/amd/xgbe/xgbe-mdio.c > index 33a9574e9e04..9822648747b7 100644 > --- a/drivers/net/ethernet/amd/xgbe/xgbe-mdio.c > +++ b/drivers/net/ethernet/amd/xgbe/xgbe-mdio.c > @@ -1329,7 +1329,7 @@ static enum xgbe_mode xgbe_phy_status_aneg(struct xgbe_prv_data *pdata) > return pdata->phy_if.phy_impl.an_outcome(pdata); > } > > -static void xgbe_phy_status_result(struct xgbe_prv_data *pdata) > +static bool xgbe_phy_status_result(struct xgbe_prv_data *pdata) > { > struct ethtool_link_ksettings *lks = &pdata->phy.lks; > enum xgbe_mode mode; > @@ -1367,8 +1367,13 @@ static void xgbe_phy_status_result(struct xgbe_prv_data *pdata) > > pdata->phy.duplex = DUPLEX_FULL; > > - if (xgbe_set_mode(pdata, mode) && pdata->an_again) > - xgbe_phy_reconfig_aneg(pdata); > + if (xgbe_set_mode(pdata, mode)) { > + if (pdata->an_again) > + xgbe_phy_reconfig_aneg(pdata); > + return true; > + } > + > + return false; Just a nit (and only my opinion) for better code readability, but you can save some indentation and make this a bit cleaner by doing: if (!xgbe_set_mode(pdata, mode)) return false; if (pdata->an_again) xgbe_phy_reconfig_aneg(pdata); return true; Thanks, Tom > } > > static void xgbe_phy_status(struct xgbe_prv_data *pdata) > @@ -1398,7 +1403,8 @@ static void xgbe_phy_status(struct xgbe_prv_data *pdata) > return; > } > > - xgbe_phy_status_result(pdata); > + if (xgbe_phy_status_result(pdata)) > + return; > > if (test_bit(XGBE_LINK_INIT, &pdata->dev_state)) > clear_bit(XGBE_LINK_INIT, &pdata->dev_state);
Powered by blists - more mailing lists