[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-Id: <20230612211500.309075-1-rrameshbabu@nvidia.com>
Date: Mon, 12 Jun 2023 14:14:51 -0700
From: Rahul Rameshbabu <rrameshbabu@...dia.com>
To: netdev@...r.kernel.org
Cc: Gal Pressman <gal@...dia.com>,
Saeed Mahameed <saeed@...nel.org>,
Tariq Toukan <tariqt@...dia.com>,
Jakub Kicinski <kuba@...nel.org>,
Richard Cochran <richardcochran@...il.com>,
Jacob Keller <jacob.e.keller@...el.com>,
Paolo Abeni <pabeni@...hat.com>,
"David S. Miller" <davem@...emloft.net>,
Rahul Rameshbabu <rrameshbabu@...dia.com>
Subject: [PATCH v3 0/9] ptp .adjphase cleanups
The goal of this patch series is to improve documentation of .adjphase, add
a new callback .getmaxphase to enable advertising the max phase offset a
device PHC can support, and support invoking .adjphase from the testptp
kselftest.
Changes:
v3->v2:
* Add information about returning -ERANGE instead of clamping
out-of-range offsets for driver implementations of .adjphase that
previously clamped out-of-range offsets.
Link: https://lore.kernel.org/netdev/13b7315446390d3a78d8f508937354f12778b68e.camel@redhat.com/
v2->v1:
* Removes arbitrary rule that the PHC servo must restore the frequency
to the value used in the last .adjfine call if any other PHC
operation is used after a .adjphase operation.
* Removes a macro introduced in v1 for adding PTP sysfs device
attribute nodes using a callback for populating the data.
Link: https://lore.kernel.org/netdev/20230523205440.326934-1-rrameshbabu@nvidia.com/
Link: https://lore.kernel.org/netdev/20230510205306.136766-1-rrameshbabu@nvidia.com/
Link: https://lore.kernel.org/netdev/20230120160609.19160723@kernel.org/
Cc: Jakub Kicinski <kuba@...nel.org>
Cc: Richard Cochran <richardcochran@...il.com>
Rahul Rameshbabu (9):
ptp: Clarify ptp_clock_info .adjphase expects an internal servo to be
used
docs: ptp.rst: Add information about NVIDIA Mellanox devices
testptp: Remove magic numbers related to nanosecond to second
conversion
testptp: Add support for testing ptp_clock_info .adjphase callback
ptp: Add .getmaxphase callback to ptp_clock_info
net/mlx5: Add .getmaxphase ptp_clock_info callback
ptp: ptp_clockmatrix: Add .getmaxphase ptp_clock_info callback
ptp: idt82p33: Add .getmaxphase ptp_clock_info callback
ptp: ocp: Add .getmaxphase ptp_clock_info callback
Documentation/driver-api/ptp.rst | 29 +++++++++++++++
.../ethernet/mellanox/mlx5/core/lib/clock.c | 31 ++++++++--------
drivers/ptp/ptp_chardev.c | 5 ++-
drivers/ptp/ptp_clock.c | 4 +++
drivers/ptp/ptp_clockmatrix.c | 36 +++++++++----------
drivers/ptp/ptp_clockmatrix.h | 2 +-
drivers/ptp/ptp_idt82p33.c | 18 +++++-----
drivers/ptp/ptp_idt82p33.h | 4 +--
drivers/ptp/ptp_ocp.c | 7 ++++
drivers/ptp/ptp_sysfs.c | 12 +++++++
include/linux/ptp_clock_kernel.h | 11 ++++--
include/uapi/linux/ptp_clock.h | 3 +-
tools/testing/selftests/ptp/testptp.c | 29 ++++++++++++---
13 files changed, 135 insertions(+), 56 deletions(-)
--
2.40.1
Powered by blists - more mailing lists