[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <MW5PR11MB5811013247814142055CF99EDD5AA@MW5PR11MB5811.namprd11.prod.outlook.com>
Date: Wed, 14 Jun 2023 22:42:48 +0000
From: "Ertman, David M" <david.m.ertman@...el.com>
To: Brett Creeley <bcreeley@....com>, "intel-wired-lan@...ts.osuosl.org"
<intel-wired-lan@...ts.osuosl.org>
CC: "daniel.machon@...rochip.com" <daniel.machon@...rochip.com>,
"simon.horman@...igine.com" <simon.horman@...igine.com>,
"netdev@...r.kernel.org" <netdev@...r.kernel.org>
Subject: RE: [PATCH iwl-next v4 02/10] ice: Add driver support for firmware
changes for LAG
> -----Original Message-----
> From: Brett Creeley <bcreeley@....com>
> Sent: Wednesday, June 14, 2023 2:24 PM
> To: Ertman, David M <david.m.ertman@...el.com>; intel-wired-
> lan@...ts.osuosl.org
> Cc: daniel.machon@...rochip.com; simon.horman@...igine.com;
> netdev@...r.kernel.org
> Subject: Re: [PATCH iwl-next v4 02/10] ice: Add driver support for firmware
> changes for LAG
>
> On 6/9/2023 2:16 PM, Dave Ertman wrote:
> > Caution: This message originated from an External Source. Use proper
> caution when opening attachments, clicking links, or responding.
> >
> >
> > Add the defines, fields, and detection code for FW support of LAG for
> > SRIOV. Also exposes some previously static functions to allow access
> > in the lag code.
> >
> > Clean up code that is unused or not needed for LAG support. Also add
> > an ordered workqueue for processing LAG events.
> >
> > Reviewed-by: Daniel Machon <daniel.machon@...rochip.com>
> > Signed-off-by: Dave Ertman <david.m.ertman@...el.com>
...
> > +/**
> > + * ice_lag_check_nvm_support - Check for NVM support for LAG
> > + * @pf: PF struct
> > + */
> > +static void ice_lag_check_nvm_support(struct ice_pf *pf)
>
> Nit, but this name is a bit misleading to me. I would expect it to be
> called something like "ice_lag_init_feature_support_flag()" or something
> similar that better describes what the function is doing.
Name changed
>
> > +{
> > + struct ice_hw_dev_caps *caps;
> > +
> > + caps = &pf->hw.dev_caps;
>
> Nit, but since you are already creating a local variable you could go
> one level further to the common_cap, so it could be:
>
> common_cap->roce_lag and common_cap->sriov_lag
Variable changed to go down one mor level.
Changes to come out in v5
DaveE
>
> > + if (caps->common_cap.roce_lag)
> > + ice_set_feature_support(pf, ICE_F_ROCE_LAG);
> > + else
> > + ice_clear_feature_support(pf, ICE_F_ROCE_LAG);
> > +
> > + if (caps->common_cap.sriov_lag)
> > + ice_set_feature_support(pf, ICE_F_SRIOV_LAG);
> > + else
> > + ice_clear_feature_support(pf, ICE_F_SRIOV_LAG);
> > +}
> > +
>
> [...]
>
Powered by blists - more mailing lists