[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <BN9PR11MB53543CA110B96C888C4385908025A@BN9PR11MB5354.namprd11.prod.outlook.com>
Date: Thu, 29 Jun 2023 07:07:04 +0000
From: "Arland, ArpanaX" <arpanax.arland@...el.com>
To: "Kitszel, Przemyslaw" <przemyslaw.kitszel@...el.com>, "Nguyen, Anthony L"
<anthony.l.nguyen@...el.com>, "Lobakin, Aleksander"
<aleksander.lobakin@...el.com>, Simon Horman <simon.horman@...igine.com>,
"intel-wired-lan@...ts.osuosl.org" <intel-wired-lan@...ts.osuosl.org>
CC: "Kitszel, Przemyslaw" <przemyslaw.kitszel@...el.com>, "Brandeburg, Jesse"
<jesse.brandeburg@...el.com>, "netdev@...r.kernel.org"
<netdev@...r.kernel.org>
Subject: RE: [Intel-wired-lan] [PATCH iwl-next v2] ice: clean up
__ice_aq_get_set_rss_lut()
> -----Original Message-----
> From: Intel-wired-lan <intel-wired-lan-bounces@...osl.org> On Behalf Of Przemek Kitszel
> Sent: Wednesday, June 7, 2023 6:40 PM
> To: Nguyen, Anthony L <anthony.l.nguyen@...el.com>; Lobakin, Aleksander <aleksander.lobakin@...el.com>; Simon Horman <simon.horman@...igine.com>; intel-wired-lan@...ts.osuosl.org
> Cc: Kitszel, Przemyslaw <przemyslaw.kitszel@...el.com>; Brandeburg, Jesse <jesse.brandeburg@...el.com>; netdev@...r.kernel.org
> Subject: [Intel-wired-lan] [PATCH iwl-next v2] ice: clean up __ice_aq_get_set_rss_lut()
>
> Refactor __ice_aq_get_set_rss_lut() to improve reader experience and limit misuse scenarios (undesired LUT size for given LUT type).
>
> Allow only 3 RSS LUT type+size variants:
> PF LUT sized 2048, GLOBAL LUT sized 512, and VSI LUT sized 64, which were used on default flows prior to this commit.
>
> Prior to the change, code was mixing the meaning of @params->lut_size and @params->lut_type, flag assigning logic was cryptic, while long defines made everything harder to follow.
>
> Fix that by extracting some code out to separate helpers.
> Drop some of "shift by 0" statements that originated from Intel's internal HW documentation.
>
> Drop some redundant VSI masks (since ice_is_vsi_valid() gives "valid" for up to 0x300 VSIs).
>
> After sweeping all the defines out of struct ice_aqc_get_set_rss_lut, it fits into 7 lines.
>
> Finally apply some cleanup to the callsite (use of the new enums, tmp var for lengthy bit extraction).
>
> Note that flags for 128 and 64 sized VSI LUT are the same, and 64 is used everywhere in the code (updated to new enum here), it just happened that there was 128 in flag name.
>
> __ice_aq_get_set_rss_key() uses the same VSI valid bit, make constant common for it and __ice_aq_get_set_rss_lut().
>
> Signed-off-by: Przemek Kitszel <przemyslaw.kitszel@...el.com>
>
> ---
> v2:
> - cover "impossible" cases with WARN ONCE + sane return after switch.
> ---
> .../net/ethernet/intel/ice/ice_adminq_cmd.h | 53 +++----
> drivers/net/ethernet/intel/ice/ice_common.c | 143 +++++++-----------
> .../net/ethernet/intel/ice/ice_hw_autogen.h | 1 -
> drivers/net/ethernet/intel/ice/ice_lib.c | 20 +--
> drivers/net/ethernet/intel/ice/ice_type.h | 9 +-
> drivers/net/ethernet/intel/ice/ice_virtchnl.c | 6 +-
> 6 files changed, 99 insertions(+), 133 deletions(-)
>
Tested-by: Arpana Arland <arpanax.arland@...el.com> (A Contingent worker at Intel)
_______________________________________________
Intel-wired-lan mailing list
Intel-wired-lan@...osl.org
https://lists.osuosl.org/mailman/listinfo/intel-wired-lan
Powered by blists - more mailing lists