[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20230727183914.69229-1-saeed@kernel.org>
Date: Thu, 27 Jul 2023 11:38:59 -0700
From: Saeed Mahameed <saeed@...nel.org>
To: "David S. Miller" <davem@...emloft.net>,
Jakub Kicinski <kuba@...nel.org>,
Paolo Abeni <pabeni@...hat.com>,
Eric Dumazet <edumazet@...gle.com>
Cc: Saeed Mahameed <saeedm@...dia.com>,
netdev@...r.kernel.org,
Tariq Toukan <tariqt@...dia.com>
Subject: [pull request][net-next V2 00/15] mlx5 updates 2023-07-24
From: Saeed Mahameed <saeedm@...dia.com>
V1->V2:
- Toss the thermal implementation patches, will be sent separately.
- Add two more cleanup patches at the end of the series.
This series adds misc updates, generally cleanups.
For more information please see tag log below.
Please pull and let me know if there is any problem.
Thanks,
Saeed.
The following changes since commit 9d0cd5d25f7d45bce01bbb3193b54ac24b3a60f3:
Merge branch 'virtio-vsock-some-updates-for-msg_peek-flag' (2023-07-27 15:51:50 +0200)
are available in the Git repository at:
git://git.kernel.org/pub/scm/linux/kernel/git/saeed/linux.git tags/mlx5-updates-2023-07-24
for you to fetch changes up to 9eca8bb8da4385b02bd02b6876af8d4225bf4713:
net/mlx5: Give esw_offloads_load/unload_rep() "mlx5_" prefix (2023-07-27 11:37:31 -0700)
----------------------------------------------------------------
mlx5-updates-2023-07-24
1) Generalize devcom implementation to be independent of number of ports
or device's GUID.
2) Save memory on command interface statistics.
3) General code cleanups
----------------------------------------------------------------
Jiri Pirko (5):
net/mlx5: Don't check vport->enabled in port ops
net/mlx5: Remove pointless devlink_rate checks
net/mlx5: Make mlx5_esw_offloads_rep_load/unload() static
net/mlx5: Make mlx5_eswitch_load/unload_vport() static
net/mlx5: Give esw_offloads_load/unload_rep() "mlx5_" prefix
Parav Pandit (2):
net/mlx5e: Remove duplicate code for user flow
net/mlx5e: Make flow classification filters static
Roi Dayan (4):
net/mlx5: Use shared code for checking lag is supported
net/mlx5: Devcom, Infrastructure changes
net/mlx5e: E-Switch, Register devcom device with switch id key
net/mlx5e: E-Switch, Allow devcom initialization on more vports
Shay Drory (4):
net/mlx5: Re-organize mlx5_cmd struct
net/mlx5: Remove redundant cmdif revision check
net/mlx5: split mlx5_cmd_init() to probe and reload routines
net/mlx5: Allocate command stats with xarray
drivers/net/ethernet/mellanox/mlx5/core/cmd.c | 223 +++++-----
drivers/net/ethernet/mellanox/mlx5/core/debugfs.c | 34 +-
drivers/net/ethernet/mellanox/mlx5/core/dev.c | 6 +-
drivers/net/ethernet/mellanox/mlx5/core/en.h | 3 -
.../net/ethernet/mellanox/mlx5/core/en_ethtool.c | 6 +-
.../ethernet/mellanox/mlx5/core/en_fs_ethtool.c | 4 -
drivers/net/ethernet/mellanox/mlx5/core/en_rep.c | 21 +-
drivers/net/ethernet/mellanox/mlx5/core/en_tc.c | 45 +--
.../net/ethernet/mellanox/mlx5/core/esw/bridge.c | 22 +-
.../ethernet/mellanox/mlx5/core/esw/bridge_mcast.c | 17 +-
.../ethernet/mellanox/mlx5/core/esw/devlink_port.c | 12 +-
drivers/net/ethernet/mellanox/mlx5/core/eswitch.c | 11 +-
drivers/net/ethernet/mellanox/mlx5/core/eswitch.h | 18 +-
.../ethernet/mellanox/mlx5/core/eswitch_offloads.c | 93 ++---
drivers/net/ethernet/mellanox/mlx5/core/lag/lag.c | 12 +-
drivers/net/ethernet/mellanox/mlx5/core/lag/lag.h | 12 +-
.../net/ethernet/mellanox/mlx5/core/lib/devcom.c | 448 +++++++++++----------
.../net/ethernet/mellanox/mlx5/core/lib/devcom.h | 74 ++--
drivers/net/ethernet/mellanox/mlx5/core/main.c | 27 +-
.../net/ethernet/mellanox/mlx5/core/mlx5_core.h | 2 +
include/linux/mlx5/driver.h | 27 +-
21 files changed, 579 insertions(+), 538 deletions(-)
Powered by blists - more mailing lists