[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <3zzbxnzkhlucscfx5h4h6k3lyhqln2nwmcsgb3dvzn6xqkhhdw@nrpekwfahkua>
Date: Mon, 18 Sep 2023 22:27:50 +0300
From: Serge Semin <fancer.lancer@...il.com>
To: Jisheng Zhang <jszhang@...nel.org>
Cc: Giuseppe Cavallaro <peppe.cavallaro@...com>,
Alexandre Torgue <alexandre.torgue@...s.st.com>, Jose Abreu <joabreu@...opsys.com>,
"David S . Miller" <davem@...emloft.net>, Eric Dumazet <edumazet@...gle.com>,
Jakub Kicinski <kuba@...nel.org>, Paolo Abeni <pabeni@...hat.com>,
Maxime Coquelin <mcoquelin.stm32@...il.com>, Shawn Guo <shawnguo@...nel.org>,
Sascha Hauer <s.hauer@...gutronix.de>, Pengutronix Kernel Team <kernel@...gutronix.de>,
Fabio Estevam <festevam@...il.com>, NXP Linux Team <linux-imx@....com>,
Vladimir Zapolskiy <vz@...ia.com>, Neil Armstrong <neil.armstrong@...aro.org>,
Kevin Hilman <khilman@...libre.com>, Jerome Brunet <jbrunet@...libre.com>,
Martin Blumenstingl <martin.blumenstingl@...glemail.com>, Emil Renner Berthing <kernel@...il.dk>,
Samin Guo <samin.guo@...rfivetech.com>, Chen-Yu Tsai <wens@...e.org>,
Jernej Skrabec <jernej.skrabec@...il.com>, Samuel Holland <samuel@...lland.org>,
Thierry Reding <thierry.reding@...il.com>, Nobuhiro Iwamatsu <nobuhiro1.iwamatsu@...hiba.co.jp>,
Russell King <linux@...linux.org.uk>, Matthias Brugger <matthias.bgg@...il.com>,
AngeloGioacchino Del Regno <angelogioacchino.delregno@...labora.com>, netdev@...r.kernel.org, linux-stm32@...md-mailman.stormreply.com,
linux-arm-kernel@...ts.infradead.org, linux-amlogic@...ts.infradead.org, linux-sunxi@...ts.linux.dev,
linux-tegra@...r.kernel.org, linux-mediatek@...ts.infradead.org
Subject: Re: [PATCH net-next v2 01/23] net: stmmac: dwmac-anarion: use
devm_stmmac_probe_config_dt()
On Sat, Sep 16, 2023 at 03:58:07PM +0800, Jisheng Zhang wrote:
> Simplify the driver's probe() function by using the devres
> variant of stmmac_probe_config_dt().
>
> The remove_new() callback now needs to be switched to
> stmmac_pltfr_remove_no_dt().
>
> Signed-off-by: Jisheng Zhang <jszhang@...nel.org>
> ---
> drivers/net/ethernet/stmicro/stmmac/dwmac-anarion.c | 12 +++---------
> 1 file changed, 3 insertions(+), 9 deletions(-)
>
> diff --git a/drivers/net/ethernet/stmicro/stmmac/dwmac-anarion.c b/drivers/net/ethernet/stmicro/stmmac/dwmac-anarion.c
> index 58a7f08e8d78..0df3a2ad0986 100644
> --- a/drivers/net/ethernet/stmicro/stmmac/dwmac-anarion.c
> +++ b/drivers/net/ethernet/stmicro/stmmac/dwmac-anarion.c
> @@ -115,7 +115,7 @@ static int anarion_dwmac_probe(struct platform_device *pdev)
> if (IS_ERR(gmac))
> return PTR_ERR(gmac);
>
> - plat_dat = stmmac_probe_config_dt(pdev, stmmac_res.mac);
> + plat_dat = devm_stmmac_probe_config_dt(pdev, stmmac_res.mac);
> if (IS_ERR(plat_dat))
> return PTR_ERR(plat_dat);
>
> @@ -124,13 +124,7 @@ static int anarion_dwmac_probe(struct platform_device *pdev)
> anarion_gmac_init(pdev, gmac);
> plat_dat->bsp_priv = gmac;
>
> - ret = stmmac_dvr_probe(&pdev->dev, plat_dat, &stmmac_res);
> - if (ret) {
> - stmmac_remove_config_dt(pdev, plat_dat);
> - return ret;
> - }
> -
> - return 0;
> + return stmmac_dvr_probe(&pdev->dev, plat_dat, &stmmac_res);
Just a general note, IMO it's better from maintainability point of
view to use the pattern:
ret = func();
if (ret)
return ret;
return 0;
Thus should you need to add any functions call after or before the
func() method invocation with possible clean-up-on-error code the
change patch will look a bit simpler and more readable.
-Serge(y)
> }
>
> static const struct of_device_id anarion_dwmac_match[] = {
> @@ -141,7 +135,7 @@ MODULE_DEVICE_TABLE(of, anarion_dwmac_match);
>
> static struct platform_driver anarion_dwmac_driver = {
> .probe = anarion_dwmac_probe,
> - .remove_new = stmmac_pltfr_remove,
> + .remove_new = stmmac_pltfr_remove_no_dt,
> .driver = {
> .name = "anarion-dwmac",
> .pm = &stmmac_pltfr_pm_ops,
> --
> 2.40.1
>
>
Powered by blists - more mailing lists