[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAJ8uoz3XiM=bKrEvfnb_y6TJv53R8-bkY1e2L0Tiad6uoTaTwQ@mail.gmail.com>
Date: Thu, 21 Sep 2023 09:28:36 +0200
From: Magnus Karlsson <magnus.karlsson@...il.com>
To: Tushar Vyavahare <tushar.vyavahare@...el.com>
Cc: bpf@...r.kernel.org, netdev@...r.kernel.org, bjorn@...nel.org,
magnus.karlsson@...el.com, maciej.fijalkowski@...el.com,
jonathan.lemon@...il.com, davem@...emloft.net, kuba@...nel.org,
pabeni@...hat.com, ast@...nel.org, daniel@...earbox.net,
tirthendu.sarkar@...el.com
Subject: Re: [PATCH bpf-next 0/8] Add a test for SHARED_UMEM feature
On Mon, 18 Sept 2023 at 11:12, Tushar Vyavahare
<tushar.vyavahare@...el.com> wrote:
>
> Implement a test for the SHARED_UMEM feature in this patch set and make
> necessary changes/improvements. Ensure that the framework now supports
> different streams for different sockets.
Thanks Tushar for contributing this new test. Had some comments in
three of the patches. Please take a look.
/Magnus
> Patch series summary:
>
> 1: Move the packet stream from the ifobject struct to the xsk_socket_info
> struct to enable the use of different streams for different sockets
> This will facilitate the sending and receiving of data from multiple
> sockets simultaneously using the SHARED_XDP_UMEM feature.
>
> It gives flexibility of send/recive individual traffic on particular
> socket.
>
> 2: Rename the header file to a generic name so that it can be used by all
> future XDP programs.
>
> 3: Move the src_mac and dst_mac fields from the ifobject structure to the
> xsk_socket_info structure to achieve per-socket MAC address assignment.
> Implement the function called generate_mac_addresses() to generate MAC
> addresses based on the required number by the framework.
>
> Require this in order to steer traffic to various sockets in subsequent
> patches.
>
> 4: Improve the receive_pkt() function to enable it to receive packets from
> multiple sockets. Define a sock_num variable to iterate through all the
> sockets in the Rx path. Add nb_valid_entries to check that all the
> expected number of packets are received.
>
> 5: The pkt_set() function no longer needs the umem parameter. This commit
> removes the umem parameter from the pkt_set() function.
>
> 6: Iterate over all the sockets in the send pkts function. Update
> send_pkts() to handle multiple sockets for sending packets.
> Multiple TX sockets are utilized alternately based on the batch size
> for improve packet transmission.
>
> 7: Modify xsk_update_xskmap() to accept the index as an argument, enabling
> the addition of multiple sockets to xskmap.
>
> 8: Add a new test for testing shared umem feature. This is accomplished by
> adding a new XDP program and using the multiple sockets. The new XDP
> program redirects the packets based on the destination MAC address.
>
> Tushar Vyavahare (8):
> selftests/xsk: move pkt_stream to the xsk_socket_info
> selftests/xsk: rename xsk_xdp_metadata.h to xsk_xdp_common.h
> selftests/xsk: implement a function that generates MAC addresses
> selftests/xsk: iterate over all the sockets in the receive pkts
> function
> selftests/xsk: remove unnecessary parameter from pkt_set() function
> call
> selftests/xsk: iterate over all the sockets in the send pkts function
> selftests/xsk: modify xsk_update_xskmap() to accept the index as an
> argument.
> selftests/xsk: add a test for shared umem feature
>
> .../selftests/bpf/progs/xsk_xdp_progs.c | 22 +-
> tools/testing/selftests/bpf/xsk.c | 3 +-
> tools/testing/selftests/bpf/xsk.h | 2 +-
> tools/testing/selftests/bpf/xsk_xdp_common.h | 12 +
> .../testing/selftests/bpf/xsk_xdp_metadata.h | 5 -
> tools/testing/selftests/bpf/xskxceiver.c | 524 +++++++++++-------
> tools/testing/selftests/bpf/xskxceiver.h | 14 +-
> 7 files changed, 376 insertions(+), 206 deletions(-)
> create mode 100644 tools/testing/selftests/bpf/xsk_xdp_common.h
> delete mode 100644 tools/testing/selftests/bpf/xsk_xdp_metadata.h
>
> --
> 2.34.1
>
>
Powered by blists - more mailing lists