[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <f5878806-5ba2-d932-858d-dda3f55ceb67@proton.me>
Date: Mon, 09 Oct 2023 13:56:58 +0000
From: Benno Lossin <benno.lossin@...ton.me>
To: Andrew Lunn <andrew@...n.ch>
Cc: FUJITA Tomonori <fujita.tomonori@...il.com>, netdev@...r.kernel.org, rust-for-linux@...r.kernel.org, miguel.ojeda.sandonis@...il.com, greg@...ah.com, tmgross@...ch.edu
Subject: Re: [PATCH net-next v3 1/3] rust: core abstractions for network PHY drivers
On 09.10.23 15:02, Andrew Lunn wrote:
> On Mon, Oct 09, 2023 at 12:19:54PM +0000, Benno Lossin wrote:
>>> +impl Device {
>>> + /// Creates a new [`Device`] instance from a raw pointer.
>>> + ///
>>> + /// # Safety
>>> + ///
>>> + /// For the duration of the lifetime 'a, the pointer must be valid for writing and nobody else
>>> + /// may read or write to the `phy_device` object.
>>> + pub unsafe fn from_raw<'a>(ptr: *mut bindings::phy_device) -> &'a mut Self {
>>> + unsafe { &mut *ptr.cast() }
>>
>> Missing `SAFETY` comment.
>
> Hi Benno
>
> It is normal on Linux kernel mailing lists to trim the text to what is
> just relevant to the reply. Comments don't get lost that way.
Sure, I will keep it in mind.
>
>>> + /// Returns true if the link is up.
>>> + pub fn get_link(&mut self) -> bool {
>>
>> I would call this function `is_link_up`.
>
> Please read the discussion on the previous versions of this patch. If
> you still want to change the name, please give a justification.
As Fujita wrote in [1], `get_foo` is not really common in Rust.
And here it seems weird to, since the return type is a bool. To
me `get_foo` means "fetch me a foo" and that is not what this
function is doing. Also given the documentation explicitly states
"Returns true if the link is up", I think that `is_link_up` or similar
fits very well.
>>> + /// Reads a given C22 PHY register.
>>> + pub fn read(&mut self, regnum: u16) -> Result<u16> {
>>> + let phydev = self.0.get();
>>> + // SAFETY: `phydev` is pointing to a valid object by the type invariant of `Self`.
>>> + // So an FFI call with a valid pointer.
>>> + let ret = unsafe {
>>> + bindings::mdiobus_read((*phydev).mdio.bus, (*phydev).mdio.addr, regnum.into())
>>> + };
>>
>> Just a general question, all of these unsafe calls do not have
>> additional requirements? So aside from the pointers being
>> valid, there are no timing/locking/other safety requirements
>> for calling the functions?
>
> Locking has been discussed a number of times already. What do you mean
> by timing?
A few different things:
- atomic/raw atomic context
- another function has to be called prior
I have limited knowledge of the C side and have cannot sift through
the C code for every `unsafe` function call. Just wanted to ensure
that someone has checked that these safety requirements are exhaustive.
>>> +macro_rules! module_phy_driver {
>>> + (@replace_expr $_t:tt $sub:expr) => {$sub};
>>> +
>>> + (@count_devices $($x:expr),*) => {
>>> + 0usize $(+ $crate::module_phy_driver!(@replace_expr $x 1usize))*
>>> + };
>>> +
>>> + (@device_table [$($dev:expr),+]) => {
>>> + #[no_mangle]
>>> + static __mod_mdio__phydev_device_table: [
>>
>> Shouldn't this have a unique name? If we define two different
>> phy drivers with this macro we would have a symbol collision?
>
> I assume these are the equivalent of C static. It is not visible
> outside the scope of this object file. The kernel has lots of tables
> and they are mostly of very limited visibility scope, because only the
> method registering/unregistering the table needs to see it.
The `#[no_mangle]` attribute in Rust disables standard symbol name
mangling, see [2]. So if this macro is invoked twice, it will result
in a compile error.
[1]: https://lore.kernel.org/rust-for-linux/20231004.084644.50784533959398755.fujita.tomonori@gmail.com/
[2]: https://doc.rust-lang.org/reference/abi.html#the-no_mangle-attribute
--
Cheers,
Benno
Powered by blists - more mailing lists