lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite for Android: free password hash cracker in your pocket
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Tue, 24 Oct 2023 13:50:16 +0200
From: Jiri Pirko <jiri@...nulli.us>
To: Michal Swiatkowski <michal.swiatkowski@...ux.intel.com>
Cc: intel-wired-lan@...ts.osuosl.org, netdev@...r.kernel.org,
	piotr.raczynski@...el.com, wojciech.drewek@...el.com,
	marcin.szycik@...el.com, jacob.e.keller@...el.com,
	przemyslaw.kitszel@...el.com, jesse.brandeburg@...el.com
Subject: Re: [PATCH iwl-next v1 00/15] one by one port representors creation

Tue, Oct 24, 2023 at 01:09:14PM CEST, michal.swiatkowski@...ux.intel.com wrote:
>Hi,
>
>Currently ice supports creating port representors only for VFs. For that
>use case they can be created and removed in one step.
>
>This patchset is refactoring current flow to support port representor
>creation also for subfunctions and SIOV. In this case port representors
>need to be createad and removed one by one. Also, they can be added and
>removed while other port representors are running.
>
>To achieve that we need to change the switchdev configuration flow.
>Three first patches are only cosmetic (renaming, removing not used code).
>Next few ones are preparation for new flow. The most important one
>is "add VF representor one by one". It fully implements new flow.
>
>New type of port representor (for subfunction) will be introduced in
>follow up patchset.

Examples please. Show new outputs of devlink commands.

Thanks!


>
>Michal Swiatkowski (15):
>  ice: rename switchdev to eswitch
>  ice: remove redundant max_vsi_num variable
>  ice: remove unused control VSI parameter
>  ice: track q_id in representor
>  ice: use repr instead of vf->repr
>  ice: track port representors in xarray
>  ice: remove VF pointer reference in eswitch code
>  ice: make representor code generic
>  ice: return pointer to representor
>  ice: allow changing SWITCHDEV_CTRL VSI queues
>  ice: set Tx topology every time new repr is added
>  ice: realloc VSI stats arrays
>  ice: add VF representors one by one
>  ice: adjust switchdev rebuild path
>  ice: reserve number of CP queues
>
> drivers/net/ethernet/intel/ice/ice.h          |  13 +-
> drivers/net/ethernet/intel/ice/ice_devlink.c  |  29 +
> drivers/net/ethernet/intel/ice/ice_devlink.h  |   1 +
> drivers/net/ethernet/intel/ice/ice_eswitch.c  | 562 ++++++++++--------
> drivers/net/ethernet/intel/ice/ice_eswitch.h  |  22 +-
> .../net/ethernet/intel/ice/ice_eswitch_br.c   |  22 +-
> drivers/net/ethernet/intel/ice/ice_lib.c      |  81 ++-
> drivers/net/ethernet/intel/ice/ice_main.c     |   6 +-
> drivers/net/ethernet/intel/ice/ice_repr.c     | 195 +++---
> drivers/net/ethernet/intel/ice/ice_repr.h     |   9 +-
> drivers/net/ethernet/intel/ice/ice_sriov.c    |  20 +-
> drivers/net/ethernet/intel/ice/ice_tc_lib.c   |   4 +-
> drivers/net/ethernet/intel/ice/ice_vf_lib.c   |   9 +-
> drivers/net/ethernet/intel/ice/ice_vf_lib.h   |   2 +-
> 14 files changed, 553 insertions(+), 422 deletions(-)
>
>-- 
>2.41.0
>
>

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ