lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date: Thu, 23 Nov 2023 22:30:33 +0800
From: Liang Chen <liangchen.linux@...il.com>
To: Yunsheng Lin <linyunsheng@...wei.com>
Cc: davem@...emloft.net, edumazet@...gle.com, kuba@...nel.org, 
	pabeni@...hat.com, hawk@...nel.org, ilias.apalodimas@...aro.org, 
	netdev@...r.kernel.org, linux-mm@...ck.org
Subject: Re: [PATCH net-next v2 1/3] page_pool: Rename pp_frag_count to pp_ref_count

On Thu, Nov 23, 2023 at 2:18 PM Yunsheng Lin <linyunsheng@...wei.com> wrote:
>
> On 2023/11/23 10:25, Liang Chen wrote:
> > To support multiple users referencing the same fragment, pp_frag_count is
> > renamed to pp_ref_count to better reflect its actual meaning based on the
> > suggestion from [1].
>
> The renaming looks good to me, some minor nit.
>
> It is good to add a cover-letter using 'git format-patch --cover-letter'
> to explain the overall background or modifications this patchset make when
> there is more than one patch.
>

Thanks for the suggestion. A cover-letter will be provided for the next version.
> >
> > [1]
> > http://lore.kernel.org/netdev/f71d9448-70c8-8793-dc9a-0eb48a570300@huawei.com
> >
> > Signed-off-by: Liang Chen <liangchen.linux@...il.com>
> > ---
> >  include/linux/mm_types.h        |  2 +-
> >  include/net/page_pool/helpers.h | 31 ++++++++++++++++++-------------
> >  2 files changed, 19 insertions(+), 14 deletions(-)
> >
> > diff --git a/include/linux/mm_types.h b/include/linux/mm_types.h
> > index 957ce38768b2..64e4572ef06d 100644
> > --- a/include/linux/mm_types.h
> > +++ b/include/linux/mm_types.h
> > @@ -125,7 +125,7 @@ struct page {
> >                       struct page_pool *pp;
> >                       unsigned long _pp_mapping_pad;
> >                       unsigned long dma_addr;
> > -                     atomic_long_t pp_frag_count;
> > +                     atomic_long_t pp_ref_count;
>
> It seems that we may have 4 bytes available for 64 bit arch if we change
> the 'atomic_long_t' to 'refcount_t':)
>
> >               };
> >               struct {        /* Tail pages of compound page */
> >                       unsigned long compound_head;    /* Bit zero is set */
> > diff --git a/include/net/page_pool/helpers.h b/include/net/page_pool/helpers.h
> > index 4ebd544ae977..a6dc9412c9ae 100644
> > --- a/include/net/page_pool/helpers.h
> > +++ b/include/net/page_pool/helpers.h
> > @@ -29,7 +29,7 @@
> >   * page allocated from page pool. Page splitting enables memory saving and thus
> >   * avoids TLB/cache miss for data access, but there also is some cost to
> >   * implement page splitting, mainly some cache line dirtying/bouncing for
> > - * 'struct page' and atomic operation for page->pp_frag_count.
> > + * 'struct page' and atomic operation for page->pp_ref_count.
> >   *
> >   * The API keeps track of in-flight pages, in order to let API users know when
> >   * it is safe to free a page_pool object, the API users must call
> > @@ -214,61 +214,66 @@ inline enum dma_data_direction page_pool_get_dma_dir(struct page_pool *pool)
> >       return pool->p.dma_dir;
> >  }
> >
> > -/* pp_frag_count represents the number of writers who can update the page
> > +/* pp_ref_count represents the number of writers who can update the page
> >   * either by updating skb->data or via DMA mappings for the device.
> >   * We can't rely on the page refcnt for that as we don't know who might be
> >   * holding page references and we can't reliably destroy or sync DMA mappings
> >   * of the fragments.
> >   *
> > - * When pp_frag_count reaches 0 we can either recycle the page if the page
> > + * pp_ref_count initially corresponds to the number of fragments. However,
> > + * when multiple users start to reference a single fragment, for example in
> > + * skb_try_coalesce, the pp_ref_count will become greater than the number of
> > + * fragments.
> > + *
> > + * When pp_ref_count reaches 0 we can either recycle the page if the page
> >   * refcnt is 1 or return it back to the memory allocator and destroy any
> >   * mappings we have.
> >   */
> >  static inline void page_pool_fragment_page(struct page *page, long nr)
> >  {
> > -     atomic_long_set(&page->pp_frag_count, nr);
> > +     atomic_long_set(&page->pp_ref_count, nr);
> >  }
> >
> >  static inline long page_pool_defrag_page(struct page *page, long nr)
> >  {
> >       long ret;
> >
> > -     /* If nr == pp_frag_count then we have cleared all remaining
> > +     /* If nr == pp_ref_count then we have cleared all remaining
> >        * references to the page:
> >        * 1. 'n == 1': no need to actually overwrite it.
> >        * 2. 'n != 1': overwrite it with one, which is the rare case
> > -      *              for pp_frag_count draining.
> > +      *              for pp_ref_count draining.
> >        *
> >        * The main advantage to doing this is that not only we avoid a atomic
> >        * update, as an atomic_read is generally a much cheaper operation than
> >        * an atomic update, especially when dealing with a page that may be
> > -      * partitioned into only 2 or 3 pieces; but also unify the pp_frag_count
> > +      * partitioned into only 2 or 3 pieces; but also unify the pp_ref_count
>
> Maybe "referenced by only 2 or 3 users" is more appropriate now?
>

Sure.
> >        * handling by ensuring all pages have partitioned into only 1 piece
> >        * initially, and only overwrite it when the page is partitioned into
> >        * more than one piece.
> >        */
> > -     if (atomic_long_read(&page->pp_frag_count) == nr) {
> > +     if (atomic_long_read(&page->pp_ref_count) == nr) {
> >               /* As we have ensured nr is always one for constant case using
> >                * the BUILD_BUG_ON(), only need to handle the non-constant case
> > -              * here for pp_frag_count draining, which is a rare case.
> > +              * here for pp_ref_count draining, which is a rare case.
> >                */
> >               BUILD_BUG_ON(__builtin_constant_p(nr) && nr != 1);
> >               if (!__builtin_constant_p(nr))
> > -                     atomic_long_set(&page->pp_frag_count, 1);
> > +                     atomic_long_set(&page->pp_ref_count, 1);
> >
> >               return 0;
> >       }
> >
> > -     ret = atomic_long_sub_return(nr, &page->pp_frag_count);
> > +     ret = atomic_long_sub_return(nr, &page->pp_ref_count);
> >       WARN_ON(ret < 0);
> >
> > -     /* We are the last user here too, reset pp_frag_count back to 1 to
> > +     /* We are the last user here too, reset pp_ref_count back to 1 to
> >        * ensure all pages have been partitioned into 1 piece initially,
> >        * this should be the rare case when the last two fragment users call
> >        * page_pool_defrag_page() currently.
>
> Do we need to rename the page_pool_defrag_page() and page_pool_is_last_frag()
> too?
>

Yeah, I think so. Once a pp page is drained, its management shifts to
being primarily governed by pp_ref_count, and there's no longer a need
to consider fragmenting. will be done in the next iteration.
> >        */
> >       if (unlikely(!ret))
> > -             atomic_long_set(&page->pp_frag_count, 1);
> > +             atomic_long_set(&page->pp_ref_count, 1);
> >
> >       return ret;
> >  }
> >

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ