lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Date: Fri, 24 Nov 2023 09:33:16 +0000
From: Ivar Simensen <is@...arespons.no>
To: Ido Schimmel <idosch@...sch.org>
CC: "mkubecek@...e.cz" <mkubecek@...e.cz>, "netdev@...r.kernel.org"
	<netdev@...r.kernel.org>
Subject: Re: ethtool module info only reports hex info

Hi Ido
Thanks for the quick response. I downloaded the latest source version today (6.6) and can confirm that the hex dump issue is still there. 
I then tried to add the suggested ID's to neltlink/module-eeprom.c as suggested, and now it's working!

Actually, it was the SFF8024_ID_SOLDERED_MODULE that solved the case, the other ID didn't have any effect on my issue.

Thanks


From: Ido Schimmel <idosch@...sch.org>
Sent: Thursday, November 23, 2023 12:29 PM
To: Ivar Simensen <is@...arespons.no>
Cc: mkubecek@...e.cz <mkubecek@...e.cz>; netdev@...r.kernel.org <netdev@...r.kernel.org>
Subject: Re: ethtool module info only reports hex info
 
On Thu, Nov 23, 2023 at 07:42:07AM +0000, Ivar Simensen wrote:
> Hi
> I'm not sure if this is a conscious decision or a bug, but I discovered a change of behavior between version 5.4 an 5.16 according to get module info from a SFP Fiber connector: "ethtool -m ens5".
>
> After upgrading a target from Ubuntu 18.04 to 22.04, I discovered that the ethtool just report a hex dump when I tried to verify my fiber SFP connectors. In 18.04 I got a report with ethtool. I have tried to upgrade from version 5.16 to 6.1 and 6.5, but it did not fix the issue. I then downgraded to version 5.4 and now it works again.
>
> The expected result with "ethtool -m ens5" was to get a human readable report, and with "ethtool -m ens5 hex on" a hexdump.
> I have tried with the flag "hex on/off" on 5.16, but the result is always hex dump.
> On version 5.4 this flag switches between hex dump and module info report as expected.

Can you try the following ethtool patch?

diff --git a/netlink/module-eeprom.c b/netlink/module-eeprom.c
index 49833a2a6a38..8b19f8e28c72 100644
--- a/netlink/module-eeprom.c
+++ b/netlink/module-eeprom.c
@@ -216,6 +216,8 @@ static int eeprom_parse(struct cmd_context *ctx)
 
        switch (request.data[0]) {
 #ifdef ETHTOOL_ENABLE_PRETTY_DUMP
+       case SFF8024_ID_GBIC:
+       case SFF8024_ID_SOLDERED_MODULE:
        case SFF8024_ID_SFP:
                return sff8079_show_all_nl(ctx);
        case SFF8024_ID_QSFP:

We might be missing more identifiers there. I can look into it next week
(around Wednesday).

If it doesn't work, you can try compiling ethtool without the new
netlink support and instead use the legacy ioctl interface:

$ ./configure --disable-netlink
$ make

Thanks

Powered by blists - more mailing lists