lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Date: Sat, 25 Nov 2023 19:53:13 +0800
From: Yunsheng Lin <>
To: Liang Chen <>, <>,
	<>, <>, <>,
	<>, <>
CC: <>, <>
Subject: Re: [PATCH net-next v3 1/3] page_pool: Rename pp_frag_count to

On 2023/11/24 15:34, Liang Chen wrote:

>  static inline void page_pool_fragment_page(struct page *page, long nr)

It seems page_pool_fragment_page() might not be a appropriate name too?

Perhaps it might be better to grep defrag/frag to see if there is other
function name might need changing.

>  {
> -	atomic_long_set(&page->pp_frag_count, nr);
> +	atomic_long_set(&page->pp_ref_count, nr);
>  }
> -static inline long page_pool_defrag_page(struct page *page, long nr)
> +static inline long page_pool_deref_page(struct page *page, long nr)

page_pool_defrag_page() related function is called by mlx5 driver directly,
we need to change it to use the new function too.

I assume that deref is short for dereference? According to:

'dereferencing means accessing the value from a certain memory location
against which that pointer is pointing'.

So I am not sure if 'deref' is the right word here as I am not a native
english speaker, But it seems 'unref' is more appropriate here if we mirror
the napi_frag_unref() function name?

Powered by blists - more mailing lists