[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <CAHS8izOk79ajSuZ=-Ca1br12H39vG6YXnHJnd5p6CDCFJz1vTg@mail.gmail.com>
Date: Tue, 12 Dec 2023 17:50:51 -0800
From: Mina Almasry <almasrymina@...gle.com>
To: Liang Chen <liangchen.linux@...il.com>
Cc: davem@...emloft.net, edumazet@...gle.com, kuba@...nel.org,
pabeni@...hat.com, hawk@...nel.org, ilias.apalodimas@...aro.org,
linyunsheng@...wei.com, netdev@...r.kernel.org, linux-mm@...ck.org,
jasowang@...hat.com
Subject: Re: [PATCH net-next v9 3/4] skbuff: Add a function to check if a page
belongs to page_pool
On Mon, Dec 11, 2023 at 8:47 PM Liang Chen <liangchen.linux@...il.com> wrote:
>
> Wrap code for checking if a page is a page_pool page into a
> function for better readability and ease of reuse.
>
> Signed-off-by: Liang Chen <liangchen.linux@...il.com>
> Reviewed-by: Yunsheng Lin <linyunsheng@...wei.com>
> Reviewed-by: Ilias Apalodimas <ilias.apalodimas@...aro.org>
Only 1 nit, feel free to ignore since especially if Jakub wants to
merge the patch asap.
Reviewed-by: Mina Almasry <almasrymina@...gle.com>
> ---
> net/core/skbuff.c | 7 ++++++-
> 1 file changed, 6 insertions(+), 1 deletion(-)
>
> diff --git a/net/core/skbuff.c b/net/core/skbuff.c
> index b157efea5dea..7e26b56cda38 100644
> --- a/net/core/skbuff.c
> +++ b/net/core/skbuff.c
> @@ -890,6 +890,11 @@ static void skb_clone_fraglist(struct sk_buff *skb)
> skb_get(list);
> }
>
> +static bool is_pp_page(struct page *page)
> +{
> + return (page->pp_magic & ~0x3UL) == PP_SIGNATURE;
> +}
> +
> #if IS_ENABLED(CONFIG_PAGE_POOL)
> bool napi_pp_put_page(struct page *page, bool napi_safe)
> {
> @@ -905,7 +910,7 @@ bool napi_pp_put_page(struct page *page, bool napi_safe)
> * and page_is_pfmemalloc() is checked in __page_pool_put_page()
> * to avoid recycling the pfmemalloc page.
> */
> - if (unlikely((page->pp_magic & ~0x3UL) != PP_SIGNATURE))
> + if (unlikely(!is_pp_page(page)))
Nit: I think the unlikely here is unnecessary anyway, and can be
removed (if without else is already unlikely).
> return false;
>
> pp = page->pp;
> --
> 2.31.1
>
>
--
Thanks,
Mina
Powered by blists - more mailing lists