[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20231220201017.0edeb8ea@hermes.local>
Date: Wed, 20 Dec 2023 20:10:17 -0800
From: Stephen Hemminger <stephen@...workplumber.org>
To: Benjamin Poirier <bpoirier@...dia.com>
Cc: netdev@...r.kernel.org, Petr Machata <petrm@...dia.com>, Roopa Prabhu
<roopa@...dia.com>
Subject: Re: [PATCH iproute2-next 00/20] bridge: vni: UI fixes
On Mon, 11 Dec 2023 09:07:12 -0500
Benjamin Poirier <bpoirier@...dia.com> wrote:
> This series mainly contains fixes to `bridge vni` command input and output.
> There are also a few adjacent changes to `bridge vlan` and `bridge vni`.
>
> Benjamin Poirier (20):
> bridge: vni: Accept 'del' command
> bridge: vni: Remove dead code in group argument parsing
> bridge: vni: Fix duplicate group and remote error messages
> bridge: vni: Report duplicate vni argument using duparg()
> bridge: vni: Fix vni filter help strings
> bridge: vlan: Use printf() to avoid temporary buffer
> bridge: vlan: Remove paranoid check
> bridge: vni: Remove print_vnifilter_rtm_filter()
> bridge: vni: Move open_json_object() within print_vni()
> bridge: vni: Guard close_vni_port() call
> bridge: vni: Reverse the logic in print_vnifilter_rtm()
> bridge: vni: Remove stray newlines after each interface
> bridge: vni: Replace open-coded instance of print_nl()
> bridge: vni: Remove unused argument in open_vni_port()
> bridge: vni: Align output columns
> bridge: vni: Indent statistics with 2 spaces
> bridge: Deduplicate print_range()
> json_print: Output to temporary buffer in print_range() only as needed
> json_print: Rename print_range() argument
> bridge: Provide rta_type()
>
> bridge/bridge.c | 2 +-
> bridge/vlan.c | 38 +++------------
> bridge/vni.c | 113 +++++++++++++++++--------------------------
> include/json_print.h | 2 +
> include/libnetlink.h | 4 ++
> lib/json_print.c | 15 ++++++
> 6 files changed, 75 insertions(+), 99 deletions(-)
>
These are all ok except the first one.
Please resubmit, and consider consolidating some of the patches.
Better to have 10 patches than 20.
Powered by blists - more mailing lists