lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <793cc4d3-aaa8-4027-8212-9a090a44c2e4@gmail.com>
Date: Fri, 8 Mar 2024 08:09:42 +0100
From: Heiner Kallweit <hkallweit1@...il.com>
To: Ratheesh Kannoth <rkannoth@...vell.com>,
 Russell King - ARM Linux <linux@...linux.org.uk>,
 Andrew Lunn <andrew@...n.ch>
Cc: David Miller <davem@...emloft.net>, Jakub Kicinski <kuba@...nel.org>,
 Paolo Abeni <pabeni@...hat.com>, netdev@...r.kernel.org
Subject: Re: [PATCH] net: phy: simplify a check in phy_check_link_status

On 08.03.2024 05:50, Ratheesh Kannoth wrote:
> On 2024-03-08 at 02:46:12, Heiner Kallweit (hkallweit1@...il.com) wrote:
>> Handling case err == 0 in the other branch allows to simplify the
>> code. In addition I assume in "err & phydev->eee_cfg.tx_lpi_enabled"
>> it should have been a logical and operator. It works as expected also
>> with the bitwise and, but using a bitwise and with a bool value looks
>> ugly to me.
>>
>> Signed-off-by: Heiner Kallweit <hkallweit1@...il.com>
>> ---
>>  drivers/net/phy/phy.c | 4 ++--
>>  1 file changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/drivers/net/phy/phy.c b/drivers/net/phy/phy.c
>> index c3a0a5ee5..c4236564c 100644
>> --- a/drivers/net/phy/phy.c
>> +++ b/drivers/net/phy/phy.c
>> @@ -985,10 +985,10 @@ static int phy_check_link_status(struct phy_device *phydev)
>>  		phydev->state = PHY_RUNNING;
>>  		err = genphy_c45_eee_is_active(phydev,
>>  					       NULL, NULL, NULL);
> IMO, better to rename "err" to "ret", and do if (ret == true). OR,
> we should fix syntax of genphy_c45_eee_is_active() to return bool (true/false)
> than doing this, because function name suggest so , xxx_is_active(). err == 0, norm is
> for success case.
> 
Return value of genphy_c45_eee_is_active() is tristate int:
<0: error
 0: eee not active
 1: eee active (implicit cast from bool to int)

This tristate behavior isn't unusual, you can find it with other phylib
functions too, another example are several of the rpm functions.
So both, 0 and 1, are success cases (from a technical perspective).

>> -		if (err < 0)
>> +		if (err <= 0)
>>  			phydev->enable_tx_lpi = false;
>>  		else
>> -			phydev->enable_tx_lpi = (err & phydev->eee_cfg.tx_lpi_enabled);
>> +			phydev->enable_tx_lpi = phydev->eee_cfg.tx_lpi_enabled;
>>
>>  		phy_link_up(phydev);
>>  	} else if (!phydev->link && phydev->state != PHY_NOLINK) {
>> --
>> 2.44.0


Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ