[<prev] [next>] [thread-next>] [day] [month] [year] [list]
Message-ID: <20240822133908.1042240-1-lizetao1@huawei.com>
Date: Thu, 22 Aug 2024 21:39:00 +0800
From: Li Zetao <lizetao1@...wei.com>
To: <davem@...emloft.net>, <edumazet@...gle.com>, <kuba@...nel.org>,
<pabeni@...hat.com>, <marcel@...tmann.org>, <johan.hedberg@...il.com>,
<luiz.dentz@...il.com>, <idryomov@...il.com>, <xiubli@...hat.com>,
<dsahern@...nel.org>, <trondmy@...nel.org>, <anna@...nel.org>,
<chuck.lever@...cle.com>, <jlayton@...nel.org>, <neilb@...e.de>,
<okorniev@...hat.com>, <Dai.Ngo@...cle.com>, <tom@...pey.com>,
<jmaloy@...hat.com>, <ying.xue@...driver.com>, <lizetao1@...wei.com>,
<linux@...blig.org>, <jacob.e.keller@...el.com>, <willemb@...gle.com>,
<kuniyu@...zon.com>, <wuyun.abel@...edance.com>, <quic_abchauha@...cinc.com>,
<gouhao@...ontech.com>
CC: <netdev@...r.kernel.org>, <linux-bluetooth@...r.kernel.org>,
<ceph-devel@...r.kernel.org>, <linux-nfs@...r.kernel.org>,
<tipc-discussion@...ts.sourceforge.net>
Subject: [PATCH net-next 0/8] Some modifications to optimize code readability
This patchset is mainly optimized for readability in contexts where size
needs to be determined. By using min() or max(), or even directly
removing redundant judgments (such as the 5th patch), the code is more
consistent with the context.
Li Zetao (8):
atm: use min() to simplify the code
Bluetooth: use min() to simplify the code
net: caif: use max() to simplify the code
libceph: use min() to simplify the code
net: remove redundant judgments to simplify the code
ipv6: mcast: use min() to simplify the code
tipc: use min() to simplify the code
SUNRPC: use min() to simplify the code
net/atm/addr.c | 4 ++--
net/bluetooth/hidp/core.c | 2 +-
net/caif/cfpkt_skbuff.c | 6 ++----
net/ceph/messenger.c | 2 +-
net/core/sock.c | 2 +-
net/ipv6/mcast.c | 5 +++--
net/sunrpc/xdr.c | 2 +-
net/tipc/monitor.c | 2 +-
8 files changed, 12 insertions(+), 13 deletions(-)
--
2.34.1
Powered by blists - more mailing lists