[<prev] [next>] [<thread-prev] [thread-next>] [day] [month] [year] [list]
Message-ID: <20240824173747.GN2164@kernel.org>
Date: Sat, 24 Aug 2024 18:37:47 +0100
From: Simon Horman <horms@...nel.org>
To: Li Zetao <lizetao1@...wei.com>
Cc: davem@...emloft.net, edumazet@...gle.com, kuba@...nel.org,
pabeni@...hat.com, marcel@...tmann.org, johan.hedberg@...il.com,
luiz.dentz@...il.com, idryomov@...il.com, xiubli@...hat.com,
dsahern@...nel.org, trondmy@...nel.org, anna@...nel.org,
chuck.lever@...cle.com, jlayton@...nel.org, neilb@...e.de,
okorniev@...hat.com, Dai.Ngo@...cle.com, tom@...pey.com,
jmaloy@...hat.com, ying.xue@...driver.com, linux@...blig.org,
jacob.e.keller@...el.com, willemb@...gle.com, kuniyu@...zon.com,
wuyun.abel@...edance.com, quic_abchauha@...cinc.com,
gouhao@...ontech.com, netdev@...r.kernel.org,
linux-bluetooth@...r.kernel.org, ceph-devel@...r.kernel.org,
linux-nfs@...r.kernel.org, tipc-discussion@...ts.sourceforge.net
Subject: Re: [PATCH net-next 3/8] net: caif: use max() to simplify the code
On Thu, Aug 22, 2024 at 09:39:03PM +0800, Li Zetao wrote:
> When processing the tail append of sk buffer, the final length needs
> to be determined based on expectlen and addlen. Using max() here can
> increase the readability of the code.
>
> Signed-off-by: Li Zetao <lizetao1@...wei.com>
> ---
> net/caif/cfpkt_skbuff.c | 6 ++----
> 1 file changed, 2 insertions(+), 4 deletions(-)
>
> diff --git a/net/caif/cfpkt_skbuff.c b/net/caif/cfpkt_skbuff.c
> index 2ae8cfa3df88..96236d21b18e 100644
> --- a/net/caif/cfpkt_skbuff.c
> +++ b/net/caif/cfpkt_skbuff.c
> @@ -298,10 +298,8 @@ struct cfpkt *cfpkt_append(struct cfpkt *dstpkt,
> if (unlikely(is_erronous(dstpkt) || is_erronous(addpkt))) {
> return dstpkt;
> }
> - if (expectlen > addlen)
> - neededtailspace = expectlen;
> - else
> - neededtailspace = addlen;
> +
> + neededtailspace = max(expectlen, addlen);
The types of all three variables involved here are u16,
so this looks correct to me. And the code replaced
seems to be an open coding of max() both in intent and function.
Reviewed-by: Simon Horman <horms@...nel.org>
>
> if (dst->tail + neededtailspace > dst->end) {
> /* Create a dumplicate of 'dst' with more tail space */
Powered by blists - more mailing lists