lists.openwall.net   lists  /  announce  owl-users  owl-dev  john-users  john-dev  passwdqc-users  yescrypt  popa3d-users  /  oss-security  kernel-hardening  musl  sabotage  tlsify  passwords  /  crypt-dev  xvendor  /  Bugtraq  Full-Disclosure  linux-kernel  linux-netdev  linux-ext4  linux-hardening  linux-cve-announce  PHC 
Open Source and information security mailing list archives
 
Hash Suite: Windows password security audit tool. GUI, reports in PDF.
[<prev] [next>] [<thread-prev] [day] [month] [year] [list]
Message-ID: <7b42df93-75d4-4c57-95e2-92404c8187e4@amd.com>
Date: Tue, 27 Aug 2024 15:32:27 -0700
From: Brett Creeley <bcreeley@....com>
To: Larysa Zaremba <larysa.zaremba@...el.com>,
 Brett Creeley <brett.creeley@....com>
Cc: netdev@...r.kernel.org, davem@...emloft.net, kuba@...nel.org,
 edumazet@...gle.com, pabeni@...hat.com, shannon.nelson@....com
Subject: Re: [PATCH v2 net-next 4/5] ionic: always use rxq_info



On 8/27/2024 5:08 AM, Larysa Zaremba wrote:
> Caution: This message originated from an External Source. Use proper caution when opening attachments, clicking links, or responding.
> 
> 
> On Mon, Aug 26, 2024 at 11:44:21AM -0700, Brett Creeley wrote:
>> From: Shannon Nelson <shannon.nelson@....com>
>>
>> Instead of setting up and tearing down the rxq_info only when the XDP
>> program is loaded or unloaded, we will build the rxq_info whether or not
>> XDP is in use.  This is the more common use pattern and better supports
>> future conversion to page_pool.  Since the rxq_info wants the napi_id
>> we re-order things slightly to tie this into the queue init and deinit
>> functions where we do the add and delete of napi.
>>
>> Signed-off-by: Shannon Nelson <shannon.nelson@....com>
>> Signed-off-by: Brett Creeley <brett.creeley@....com>
>> ---
>>   .../net/ethernet/pensando/ionic/ionic_lif.c   | 55 +++++++------------
>>   1 file changed, 19 insertions(+), 36 deletions(-)
>>
>> diff --git a/drivers/net/ethernet/pensando/ionic/ionic_lif.c b/drivers/net/ethernet/pensando/ionic/ionic_lif.c

<snip>

>> -static int ionic_xdp_register_rxq_info(struct ionic_queue *q, unsigned int napi_id)
>> +static int ionic_register_rxq_info(struct ionic_queue *q, unsigned int napi_id)
>>   {
>>        struct xdp_rxq_info *rxq_info;
>>        int err;
>> @@ -2698,45 +2699,27 @@ static int ionic_xdp_register_rxq_info(struct ionic_queue *q, unsigned int napi_
>>        return err;
>>   }
>>
>> -static int ionic_xdp_queues_config(struct ionic_lif *lif)
>> +static void ionic_xdp_queues_config(struct ionic_lif *lif)
> 
> I think this function should also get a new name that would reflect the fact
> that it is just updating the XDP prog on rings. Also, ionic_xdp_queues_config
> sounds a little bit like configuring XDP_TX/xdp_xmit queues, but here we have rx
> queues only.

Yeah that makes sense. We can rename it to something closer to the 
function's contents/purpose.

Thanks,

Brett
> 
>>   {
>>        struct bpf_prog *xdp_prog;
>>        unsigned int i;
>> -     int err;
>>
>>        if (!lif->rxqcqs)
>> -             return 0;
>> +             return;
>>
>> -     /* There's no need to rework memory if not going to/from NULL program.  */
>> +     /* Nothing to do if not going to/from NULL program.  */
>>        xdp_prog = READ_ONCE(lif->xdp_prog);
>>        if (!xdp_prog == !lif->rxqcqs[0]->q.xdp_prog)
>> -             return 0;
>> +             return;
>>
>>        for (i = 0; i < lif->ionic->nrxqs_per_lif && lif->rxqcqs[i]; i++) {
>>                struct ionic_queue *q = &lif->rxqcqs[i]->q;
>>
>> -             if (q->xdp_prog) {
>> -                     ionic_xdp_unregister_rxq_info(q);
>> +             if (q->xdp_prog)
>>                        q->xdp_prog = NULL;
>> -                     continue;
>> -             }
>> -
>> -             err = ionic_xdp_register_rxq_info(q, lif->rxqcqs[i]->napi.napi_id);
>> -             if (err) {
>> -                     dev_err(lif->ionic->dev, "failed to register RX queue %d info for XDP, err %d\n",
>> -                             i, err);
>> -                     goto err_out;
>> -             }
>> -             q->xdp_prog = xdp_prog;
>> +             else
>> +                     q->xdp_prog = xdp_prog;
>>        }
>> -
>> -     return 0;
>> -
>> -err_out:
>> -     for (i = 0; i < lif->ionic->nrxqs_per_lif && lif->rxqcqs[i]; i++)
>> -             ionic_xdp_unregister_rxq_info(&lif->rxqcqs[i]->q);
>> -
>> -     return err;
>>   }
>>
>>   static int ionic_xdp_config(struct net_device *netdev, struct netdev_bpf *bpf)
>> --
>> 2.17.1
>>
>>

Powered by blists - more mailing lists

Powered by Openwall GNU/*/Linux Powered by OpenVZ